In tmux, when having separate panes open, I do Ctrl-B ↑ to switch to the pane above. Great. Except that if the next key I want to press is also an arrow key (e.g. I want to go to the bash prompt above and search history for previous command) then this keystroke is also interpreted by tmux.

It seems there's a timeout period before tmux releases control of the keyboard. How can I reduce that?


You can configure this with the repeat-time option:

repeat-time time
Allow multiple commands to be entered without pressing the prefix-key again in the specified time milliseconds (the default is 500). Whether a key repeats may be set when it is bound using the -r flag to bind-key. Repeat is enabled for the default keys bound to the resize-pane command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.