1

I updated motherboard on x240 computer node, now the ethernet interfaces show up as eth2 and eth3 previously it was eth0 and eth1.

I tried to delete /etc/udev/rules.d/70-persistent-net.rules file but the problem still persists. On boot it says that eth3 and eth2 cannot be recognized or mapped. The new mac addresses are clearly illustrated and mapped to name files eth2 and eth3.

I did change in file ifcfg eth2 and eth3 and change its name to eth0 and eth1 respectively. But this too had little effect, do I need this change to be done in 70-persistent file as well? I.e. change name to match the entry in ifcfg?.

Is there a way i can bring the old mapping back? Thanks.

3

Now suppose you want to rename eth2 as eth0 then :

Open /etc/udev/rules.d/70-persistent-net.rules with your favorite editor and Do below changes

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="xx:xx:xx:xx:xx", ATTR{type}=="1", KERNEL=="eth2", NAME="eth0"

Note:- if that rule file does not exists then just create it, and replace "xx:xx:xx:xx:xx" with your NIC mac address.

after doing change just run Or if you are using Ubuntu then reboot the system because below command work and tested in CentOS:

udevtrigger

then check using :

ifconfig -a

then configure RHEL/CentOS = "/etc/sysconfig/network-scripts/ifcfg-eth0" Or Ubuntu = "/etc/network/interfaces"

  • Tried but didn't worked – asadz Jul 9 '13 at 14:57
  • @asadz have you rebooted system ? – Rahul Patil Jul 9 '13 at 15:03
  • @asadz also please update of output what you have done changes – Rahul Patil Jul 9 '13 at 15:05
  • Udevtrigger was said as unrecognised – asadz Jul 9 '13 at 16:22
  • in Ubuntu , you need to reboot , as I mentioned.. , so you did that ? – Rahul Patil Jul 9 '13 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.