2

I have installed peppermint 4 but after restarting it, the grub menu didn't show up and now it boots straight into Windows. I went back into peppermint by using "Try out Peppermint" option from the boot USB. I've also run

sudo fdisk -l

and this is the output.

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd9aacbf3

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 821247 409600 27 Hidden NTFS WinRE
/dev/sda2 821248 489330687 244254720 7 HPFS/NTFS/exFAT
/dev/sda3 489330688 976773119 243721216 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x99954f66

Device Boot Start End Blocks Id System
/dev/sdb1 2048 557340671 278669312 7 HPFS/NTFS/exFAT
/dev/sdb2 * 557340672 557828095 243712 83 Linux
/dev/sdb3 557830142 691828735 66999297 5 Extended
/dev/sdb5 557830144 567828479 4999168 83 Linux
/dev/sdb6 567830528 667828223 49998848 83 Linux
/dev/sdb7 667830272 691828735 11999232 82 Linux swap / Solaris

Disk /dev/sdc: 16.2 GB, 16231956480 bytes
140 heads, 32 sectors/track, 7076 cylinders, total 31703040 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdc1 * 32 31703039 15851504 c W95 FAT32 (LBA)

The /boot partition for peppermint was set at /dev/sdb.

I have also tried to use type this code:

sudo mount /dev/sdb2 /mnt
chroot /mnt

It has managed to mount it but after trying chroot /mnt it says:

Operation not allowed.

What can I do to enable grub now?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.