3

Few days ago I updated my openSUSE 12.3 system from Kernel 3.9.8-1.gf3348a8-desktop to 3.10.0-1.g3dcd746-desktop and since then, turbo mode of my i7 3520M is enabled by default and it does not throttle down when idle. It is constantly running at 3.6GHz.

The intel_pstate module is enabled by default, thus any userspace settings are ignored (as intended). Tools such as cpufreq or cpupower are not installed any more on my machine.

Booting the 3.9.8 Kernel still shows its old behaviour, that the CPU is throttling as expected. In addition, adding intel_pstate=disable to the kernel command line deactivates the intel_pstate module resulting in the desired behaviour of a throttling CPU.

Another point of minor interest is, that I'm not able to trigger the turbo mode of my CPU if it is throttling (i.e. Kernel 3.9.8 or disabled intel_pstate).

Any help is appreciated.

0

I had good results with disabling and enabling cores again, this makes the pstate driver work a lot better:

echo -n 1 | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo
function set_cores_online()
{
  typeset core=1
  while [[ -f /sys/devices/system/cpu/cpu${core}/online ]]
  do
    echo -n ${1:-1} | sudo tee /sys/devices/system/cpu/cpu${core}/online
    : $((core++ ))
  done
}
set_cores_online 0
set_cores_online 1

Note1

It does scale down but also stays there, I was not able to get the CPU working "fast" again

Note2

Added disabling turbo mode as it seems to be prerequisite for it to work, but enabling it again does not make it full power again - so you need to find perfect configuration for you

Update3

Got tired of running it manually and wrote a script for it https://github.com/mpapis/home_dotfiles/blob/master/bin/cpu - use it: cpu slow

  • So do you run this script on each system boot to actually make intel_pstate driver work properly? – Torbjörn Jul 8 '13 at 8:09
  • I shutdown very rarely, so for no just disable/enable a CPU after start and it's fine for me, wrote the script just for practice - but it works – mpapis Jul 8 '13 at 12:31
  • Finally I had time to test this. Unfortunately, the cores do not scale down. :( Output of this function is: 000111. Which seems ok. Guess, I've to wait for a new kernel release. – Torbjörn Jul 13 '13 at 6:49
  • maybe it works only on some sub-version mine is 3.10.0-1.g3dcd746-desktop - and more after sleep2ram it now works more dynamically scaling a bit up when needed – mpapis Jul 13 '13 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.