When I do this in my terminal:

echo -e "\xF0\x9f\x8d\xba"

I get a cool beer mug in my terminal: 🍺

However, when I start screen, and try the same, I'm getting a �. How do I get the nice beer mug?

This is my .screenrc:

nethack on
startup_message off
defscrollback 3000
hardstatus on
hardstatus alwayslastline
hardstatus string "%{.bW}%-w%{.rW}%n %t%{-}%+w %=%{..G} %H %{..Y} %m/%d %c"
termcapinfo xterm 'bc@:bs@'
ignorecase on
maptimeout 0
vbell off
defutf8 on
defencoding utf8

Also running screen with the -U option doesn't help.

  • � is U+FFFD, the Unicode replacement character. This means your computer does not recognize the character that the bytes are trying to represent. Are you switching from your physical terminal to a terminal emulator during these tests by any chance?
    – Andrew B
    Jul 4, 2013 at 16:03
  • When I do it in my terminal without starting screen it works, when I start screen and do the same it doesn't work. It's on the same machine and in the same terminal. I use a terminal emulator all the time.
    – gitaarik
    Jul 4, 2013 at 16:11
  • what terminal emulator are you using?
    – dawud
    Jul 4, 2013 at 16:39

3 Answers 3


It's a apparently a known bug: No characters beyond the BMP are displayed, as screen apparently only has a two byte buffer for characters.

(It works in tmux).

  • That's a bummer.. Tried tmux in the past but it crashed a lot. Maybe I could give it another try at some point...
    – gitaarik
    Jul 5, 2013 at 7:36
  • 1
    Btw update: I've been on tmux for a long time now and loving it. Almost never crashes and has great configurability and plugins. Took some time to configure it so that it became nice to work in though, but it's certainly worth the effort :).
    – gitaarik
    Apr 21, 2016 at 20:44
  • 6
    Update: the bug is fixed as of v4.2.0! sudo apt install screen=4.2.1-2~ubuntu14.04.1 worked for me. Dec 3, 2016 at 6:09
  • It's worth noting that unicode chars do not work in the hardstatus of GNU screen, even in version 4.6.2-1ubuntu1 on Lubuntu Bionic Beaver (18.04).
    – zrajm
    Feb 11, 2020 at 2:15

It's known issue for old screen. It is fixed as of v4.2.0

Update screen to latest version:

sudo apt upgrade screen

Other commands:

  • see available screen versions: apt list -a screen
  • install exact version: sudo apt install screen=4.3.1-2build1

For me emojis started work in GNU Screen (in local and remote server screens) after fixing locale. On my Mac I added to


those lines:

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.