7

There's no output from my HDMI port and my TV shows NO Signal.

My Current OS: Linux Mint 15

Things I have tried with no success:

  1. Change the HDMI cable
  2. Install another operating system ( Windows 7, Windows 8 and Ubuntu)
  3. Tried to connect to a different TV

Eventually I thought that my HDMI port was damaged, until I ran the following command aplay -l:

output:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

As you guys can see, I saw HDMI 0, so there's nothing wrong with my HDMI port.

Furthermore xrandr does not detect it, please take a look at xrandr output as well:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 32767 x 32767
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768       59.6*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
TV1 disconnected (normal left inverted right x axis y axis)

HDMI is not listed, please guys I need your help with this, there's no response when I connect my HDMI cable to the computer. There's no video/audio output on my TV screen.

closed as too broad by Evan Carroll, Archemar, derobert, jimmij, GAD3R Apr 29 '18 at 16:15

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Did you manage to solve it? – Ole Tange Jan 12 '14 at 0:48
  • 4 years later, and we still have no idea what your problem is and it's not reproducible. VTC. – Evan Carroll Apr 28 '18 at 19:34
2

So you've tried four OSs, including Windows, and it didn't work with any of them? Then it's very likely to be a hardware problem. The data in aplay -L doesn't preclude a hardware problem because that information comes from your audio chipset, not the actual HDMI port. If it's still under warranty, contact the manufacturer.

1

I realize this is an old question, but I had similar problems and I hope that my findings will be helpful to some of you:

In Linux Mint 18, I had trouble finding or enabling my TV connected via hdmi when it was turned off. I could enable it via the "Re-Detect display devices" Shortcut -

<MOD>+p or <Winkey>+p

by default, but without this I could not enable or use the device in xrandr or arandr.

later on I realized that, in order to use the display in xrandr, I had to do three things:

1) Disable unused displays with

xrandr --output HDMI-1-2 --off --output DVI-I-1-3 --off

This step was especially important because my card only supports 2 simultaneous outputs, so it wouldnt let me enable the third while the other two were active.

2) Enable the wanted display with

xrandr --output HDMI-1 --auto

For some reason, I had to do this as xrandr wouldnt detect or activate the monitor just by setting the mode with the following (and last) command

3) Set the preferred mode with

xrandr --output HDMI-1 --mode 1920x1080 --pos 0x0

after enabling the Output in the step before, the Display should now accept your monitor settings.

Bonus) Creating the commands you can get a quick list of your available displays for the --output option above in terminal by typing

xrandr | grep connect

if you need help in setting the overall settings you can also use a gui tool called ARandr, which can be installed with the command

sudo apt-get install arandr

this tool will allow you to position your screens and save the settings to a .sh file which will contain the xrandr command for your setup, you will only have to add the --auto option manually.

Note) My experience You could combine all the options into one xrandr command, but this gave me some problems and weird behavior. I found most reliable to add those lines to a script one by one and even add a sleep 1 between the three lines.

0

I think this is an error at the hardware level: I had this same issue that started in the middle of an Linux Mint (KDE) Session. XRandR and Display Configuration tools both stopped detecting my displays even after reboot. Unplugging and re-plugging in the cables and trying different monitors didn't help.

What worked: Booting into an old Semplice Linux (2011) distro and using the XRandR to 'turn on' HDMI. Upon booting back into Linux Mint, my HDMI screens were suddenly detected (after weeks of not seeing them).

Unfortunately, I borked that partition trying to update (the software needed to remove the filesystem got removed in an attempt to resolve dependencies), so I can't fully recapitulate exactly where the setting was.

  • i'm confused how you used XRandR to "turn on" a display when you're saying XRandR stopped detecting your problem. It sounds like your solution was changing a distro -- but that's really not useful as it doesn't identity the problem. You threw the baby out with the bathwater, and something may have worked for you, but you don't understand why. – Evan Carroll Apr 28 '18 at 19:33
  • I'm not exactly sure what happened, but I think somehow a BIOS level setting for display was switched off, and Linux Mint was not interfacing with the BIOS. The fix still stands, I just booted into another distro (it could of been a live CD), and turned it 'on' there. The baby wasn't thrown out with this bath, but rather when it started to act autistic when after trying to do a web upgrade of the distro (which Linux Mint usually recommends against). – virtualxtc Apr 28 '18 at 20:33
  • XRandR doesn't keep any state, or set any stateful features in videocards or the bios/uefi. There is no way booting in and doing anything will preserve a change to another boot up. Which gets back to the point: it worked for you, which is awesome for you but it's not all that useful for others, and it may even confuse them or discourage them. – Evan Carroll Apr 28 '18 at 20:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.