I am installing the R package (R-3.0.1) in Red Hat Linux 6.0.

Initially when I tried to install it gave the error “F77 compiler not found”. I installed the compiler and tried it again, now the error I am getting is

configure: error: --with-readline=yes (default) and headers/libs are not available

I tried ./configure --with-x=no but it doesn't work, again I am getting the same error.


Don't bother with all this trouble. Just yum install R; it's in the EPEL repository, which you should already be using.

  • Hi Micheal, thanks for the reply.. i am getting error in installing R Could you please tell how to get EPEL for Redhat 6.0 ?? i mentioned the error i am getting .. yum install R Loaded plugins: refresh-packagekit Setting up Install Process No package R available. Error: Nothing to do – sridhar Jun 11 '13 at 10:06
  • 2
    Don't use Red Hat unless you've actually paid for it and registered the machine. If you aren't willing or able to pay for it, use CentOS instead. – Michael Hampton Jun 11 '13 at 17:16
  • I think my Redhat is registered.. – sridhar Jun 12 '13 at 3:44
  • Hi,i couldnt rectify the problem.. i gave yum install R but it shows there is no package R.. – sridhar Jul 3 '13 at 7:56
  • Did you add the epel repository as Michael H wrote in his answer? – Jenny D Jul 3 '13 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.