1

In the interactive shell oh PHP Delete key is not working and produce ~ instead. Anyone know how to get this key to work? I am using Ubuntu 13.04 if this does matter.

8
  • have you tried ctrl + backspace ?
    – h3rrmiller
    Jul 3, 2013 at 11:58
  • @h3rrmiller Is working with Ctrl+D, but still I want to use Delete key. Jul 3, 2013 at 12:14
  • Can you explain how you get to the php prompt?
    – slm
    Jul 5, 2013 at 18:47
  • Can you post the contents of either your ~/.inputrc (if you have one), or /etc/inputrc
    – Poundex
    Jul 5, 2013 at 19:54
  • @sim From gnome-terminal with php -a Jul 5, 2013 at 20:27

1 Answer 1

2
+50

Have you tried running rlwrap -a around the PHP interactive shell? rlwrap fixes many of these types of problems for me in various REPLs.

1
  • I've installed first rlwrap with sudo apt-get rlwrap and I started PHP interactive shell with rlwrap -a php -a and now every key and shortcut key is working like in the default bash shell. Thank you! Jul 9, 2013 at 5:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .