0

When I try to send email from my new system:

Distributor ID: Scientific
Description: Scientific Linux release 6.4 (Carbon) 
Release: 6.4 
Codename: Carbon

with sendmail Version 8.14.4

I have this error message on maillog:

Jul 1 12:17:43 server5 sendmail[5806]: NOQUEUE: connect from localhost.localdomain [127.0.0.1]
Jul 1 12:17:43 server5 sendmail[5806]: AUTH: available mech=DIGEST-MD5 ANONYMOUS GSSAPI PLAIN CRAM-MD5 LOGIN, allowed mech=EXTERNAL GSSAPI KERBEROS_V4 DIGEST-MD5 CRAM-MD5
Jul 1 12:17:43 server5 sendmail[5806]: r61AHhHH005806: Milter: no active filter
Jul 1 12:17:43 server5 sendmail[5806]: r61AHhHH005806: --- 220 server5.eda ESMTP Sendmail 8.14.4/8.14.4; Mon, 1 Jul 2013 12:17:43 +0200
Jul 1 12:17:43 server5 sendmail[5806]: r61AHhHH005806: --- 421 4.4.1 server5.eda Lost input channel from localhost.localdomain [127.0.0.1]
Jul 1 12:17:43 server5 sendmail[5806]: r61AHhHH005806: localhost.localdomain [127.0.0.1] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
Jul 1 12:17:43 server5 sendmail[5807]: NOQUEUE: connect from server5 [192.168.1.12]
Jul 1 12:17:43 server5 sendmail[5807]: AUTH: available mech=DIGEST-MD5 ANONYMOUS GSSAPI PLAIN CRAM-MD5 LOGIN, allowed mech=EXTERNAL GSSAPI KERBEROS_V4 DIGEST-MD5 CRAM-MD5
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: Milter: no active filter
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 220 server5.eda ESMTP Sendmail 8.14.4/8.14.4; Mon, 1 Jul 2013 12:17:43 +0200
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: <-- EHLO 192.168.1.12
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250-server5.eda Hello server5 [192.168.1.12], pleased to meet you
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250-ENHANCEDSTATUSCODES
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250-PIPELINING
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250-8BITMIME
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250-SIZE
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250-DSN
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250-ETRN
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250-AUTH GSSAPI DIGEST-MD5 CRAM-MD5
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250-DELIVERBY
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 250 HELP
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: <-- AUTH DIGEST-MD5
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 334 bm9uY2U9ImxFUmRaUEh6NnZQVzVxU3lsNXJwUnZZamRuaksrNUwyZk5jRnN6K2JSQ3M9IixyZWFsbT0ic2VydmVyNS5lZGEiLHFv cD0iYXV0aCxhdXRoLWludCxhdXRoLWNvbmYiLGNpcGhlcj0icmM0LTQwLHJjNC01NixyYzQsZGVzLDNkZXMiLG1heGJ1Zj04MTky LGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 535 5.7.0 authentication failed
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: AUTH failure (DIGEST-MD5): generic failure (-1) SASL(-1): generic failure: unable canonify user and get auxprops, relay=server5 [192.168.1.12]
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: --- 421 4.4.1 server5.eda Lost input channel from server5 [192.168.1.12]
Jul 1 12:17:43 server5 sendmail[5807]: r61AHhhS005807: server5 [192.168.1.12] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA

Note: server5 and localhost are the same machine.

This doesn't happen on this machine:

Distributor ID: ScientificSL 
Description: Scientific Linux SL release 5.5 (Boron) 
Release: 5.5 
Codename: Boron

with sendmail Version 8.13.8

What's wrong with the most recent version?

  • I think I have found the issue: when the email is sent from an address other than 127.0.0.1 authorization is required even if ip is on the same machine. How can I avoid to make request authorization for a given ip ? – famedoro Jul 3 '13 at 9:29
  • Check sendmail.com/sm/open_source/docs/configuration_readme and search for "ACCEPTING MAIL FOR MULTIPLE NAMES" it explains how to enable to mail from the same host if multiple hostnames/ips' – BitsOfNix Jul 3 '13 at 12:36
  • Alexandre, thank you very much for your replies – famedoro Jul 4 '13 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.