The problem is that my fan is too loud and working nonstop on my desktop. I have tried so far:

Ubuntu 13.04, Linux Mint 15

and I had in both the same fan problem (nonstop working fan and very loud). In Windows 7 it's working nice.

Is this only a problem of Gnome distros or KDE or Xfce based would work better for me?

My configuration is:

HP Pro 3410 Microtower PC.

Graphic card: AMD Radeon HD 6570

Board: 2A9C 1.1

Bus Clock: 133 megahertz

BIOS: American Megatrends Inc. 6.14 11/05/2010

Processor: 3,20 gigahertz Intel Core i3 550


I have tried these drivers so far:

xserver-xorg-video-ati, version: 1:7.1.0-0ubuntu2

fglrx Version: 2:9.010-0ubuntu3

fglrx-updates Version 2:9.012-0ubuntu1

But the fan is still blowing like a maniac.


"Do all distrbutions have the same drivers for ATI cards?":

If you have an AMD graphic card, then basically you have two options:

  1. You can use the mostly closed source "AMD Catalist Proprietary Display Driver" which comes from AMD. (here Fglrx stands for "Fire Gl and Radeon X")
  2. You can use the open source "Gallium 3D" which is developed by VMware and volunteers.

These two can be used with practically any (desktop) distribution, because the dependencies in terms of kernel and libraries can be satisfied in practically any (desktop) distribution. The above mentioned two can greatly differ in stability and performance, but for such information I suggest you to read reviews on related forums.

"Is this only a problem of Gnome distros or KDE or Xfce based would work better for me?"

Some desktop environments are much more resource hungry than others, Xfce is known to have much lower requirements, but instead of trying different distribution/desktop environment combination, you should try different versions of drivers. The information that you provided implies that you use Catalist 12.11, so I suggest you to try the latest.

  • Thanks, I have installed AMD Catalist Proprietary Display Driver from their site. At least I have learned how to run ".run" extension files ;). Then there was a problem with a black border around my monitor, but I solved that by setting overscaling to 0%. Thanks – Derfder Jun 30 '13 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.