My laptop have a ethernet card and a wifi card. Ethernet line have maximum download rate at 1.5MiB/sec and wifi is over 1MiB/sec too, but it seem only have one NIC can working at a moment (if I turn on ethernet then system not using wifi althought it's connected). I want using 2 NICs at the same time for faster internet speed (may be around 2.5MiB/sec??), how can I do that?

I mean, Download Them All plugin for firefox report my internet speed (over ethernet card) when download a movie is 1.5MB/s and other internet speed (over wireless card) is 1.0MB/s. How can I use two NICs at the same time to download a file?

Update 2: Here is two different internet connections for wifi and ethernet, once have maximum is 1.5MB/s and once have maximum is 1.0MB/s

My laptop is: HP CQ40 129TU (pretty old :D)
Wireless card: BCM4312 (b43 module)

  • 1
    What's your Internet speed? What's your laptop? What's your router?
    – Cry Havok
    Commented Jun 30, 2013 at 8:25
  • Yes - this is called bonding.
    – Mel Boyce
    Commented Jun 30, 2013 at 10:01
  • 3
    If both your ethernet and Wifi use the same internet connection, you won't be able to increase the speed by using both at the same time -- you're still limited by your internet connection speed.
    – Johnny
    Commented Jun 30, 2013 at 15:37
  • @Johnny: No, these are two different internet connections for wifi and ethernet Commented Jul 1, 2013 at 3:17
  • 1
    The ethernet card in that laptop is 10/100, capable of over 10MB/s. The wireless card in that laptop is similarly capable of much more than the 1.0MB/s you are observing. Your network cards are not the limiting factor, the connection between your building's network and the rest of the Internet is.
    – Ben Voigt
    Commented Jul 3, 2013 at 20:20

3 Answers 3


One method for configuring multiple NIC cards is through the use of what's called bonding. It goes by other names as well:

Using NetworkManager

What version of NetworkManager are you using? Version 0.9.8 is the first that purports to offer support for network bonding.

excerpt from phoronix.com

  • Add a "slaves" property to Bond devices
  • Bond interfaces now wait for a ready slave before starting automatic IP configuration

There is also this blurb on the Fedora website regarding bonding.

Plase wait for NetworkManager 0.9.8 before considering this feature fully working. I have prepared a feature page for this.

This tutorial looks to show how to set it up using NetworkManager. I don't have this version so I can't confirm the steps.


An alternative way to set it up if you're not using NetworkManager is to set it up manually. This method isn't as flexible and I'd avoid it if one of the ethernet devices is wireless. The steps are covered here (Fedora specific) in this tutorial.

  • thanks for the answer, i'll try this way and report the result soon ;) Commented Jul 1, 2013 at 3:24
  • 2
    This method can't work with two internet connections. It could only help if you had one fast internet connection, and two strangely slow local links.
    – sourcejedi
    Commented Jul 3, 2013 at 18:25
  • 1
    @sourcejedi - as is the case with this question, given he's getting 1.5MiB on his ethernet. I'd agree something is mis-configured. You'd be correct that the above will only work when both network devices are connected to the same network (same switch or router for example). So if you're getting 2 IP addresses from your ISP channel bonding isn't an option.
    – slm
    Commented Jul 3, 2013 at 18:50

This would be possible if you could implement multi-path TCP on both your computer and the servers you're connecting to. (Or SCTP with "concurrent multi-path". There were patches for SCTP for Firefox at some point). I understand it's still in the research stage at the moment.

Bonding won't work... the alternative name "link aggregation" might help explain it. Bonding lets you merge multiple links between A and B (assuming B co-operates with A). You can't merge a link from A to B with a link from A to C.


That can't work. Here's why.

Install and run mii-tool:

$ sudo mii-tool eth0
eth0: negotiated 100baseTx-FD, link ok

If eth0 doesn't work, run ip link, and look for the device name that's not lo (loopback) or wlan0 (wireless). It probably looks like p0p1. This would be the case on current Fedora Linux, for example.

Your ethernet connection will be 100something or 1000something. This means 100M or 1000M bits per second. There are 8 bits in a byte (and protocol overhead at various levels. So we'd expect around 10M or even 100M bytes per second.

So the 1.5M bytes per second is not due to your ethernet connection. The limiting factor is the connection from your home router to your Internet Service Provider (ISP). You might be able to pay more for a faster connection, particularly if there are fibre-optic providers in your area.

  • Sorry for vague question, I have updated my question, Please help me solve this, Thanks you very much! Commented Jun 30, 2013 at 11:02
  • Sorry, it's not possible to solve this question. We're trying to explain why :-). See Johnny's comment.
    – sourcejedi
    Commented Jun 30, 2013 at 17:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .