I ran my Rsnapshot backup today but my external drive became full half-way through the incremental backup (I have about 20 incremental backups now).

rsync: write failed on "<path>": No space left on device (28)

I now have an hourly.0 directory which I assume contains an incomplete incremental backup. How do I recover from this situation without losing data, and redo the backup?

My initial thoughts are to:

  1. Delete hourly.0 (because it contains an incomplete incremental backup of data since hourly.1 ?)
  2. Free up space on the external drive or move the entire contents of my external drive to a larger drive
  3. Re-run Rsnapshot.

My biggest concern is that deleting hourly.0 will somehow confuse Rsnapshot and cause problems. But is this the right approach?

  • 1
    This question is a duplicate of this question: unix.stackexchange.com/questions/63553/…. Even though this question doesn't have an answer it has a link to an answer on askubuntu: askubuntu.com/questions/6663/…. The answer is NO you can't resume it.
    – slm
    Commented Jun 29, 2013 at 12:29
  • 2
    I think you will find my old question Rename multiple directories decrementing sequence number? useful; it was about pretty much exactly this scenario (even including rsnapshot). Delete hourly.0 (I suggest moving it out of the way before deleting it), run the snippet in the accepted answer after adjusting it to your specific situation, and re-run rsnapshot after making more disk space available through some means. I did it back then and it worked wonderfully.
    – user
    Commented Jun 29, 2013 at 13:37
  • If someone wants to it probably would be worth having the gist of the answer to the askubuntu answer copied over here as well since this is now the 2nd question on the same topic.
    – slm
    Commented Jun 30, 2013 at 1:43
  • Thank you all. Sorry i cannot comment yet. Well recovering the partial backup was easy, helped by your comment Michael (went manualy after I tried the script you linked with no success). Then I searched (and found) a wrapper that helps getting full backups only, and automatize unrolling. Summarized the result at the AskUbuntu question.
    – tuk0z
    Commented Feb 17, 2015 at 15:29

1 Answer 1


If you have the output of rsnapshot available, you can safely repeat the rsync command that it used. You do not (and should not) delete hourly.0 if you're going to do this.

For example, on one of my systems this is (almost) what gets run by rsnapshot, so this could be copied and pasted and rerun:

/usr/bin/rsync -avzS --delete --delete-excluded --numeric-ids --fake-super \
    --exclude-from=/usr/local/etc/rsnapshot/EXCLUDE-qnap.inc \
    --rsh=/usr/bin/ssh \
    --link-dest=/backup/Rsync/NewZealand/QNAP/Data/hourly.1/share/ \
    [email protected]:/share/ \

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .