3

I have installed Fedora after using Windows 7. I have two screens connected to my computer: a TV and a 19" monitor.

I only want one screen active at a time. I'd like to be able to switch which screen is active using a simple mouse-click or keyboard combination. From the settings window, all I can see is how to clone/extend the screen, which is not what I want to do.

enter image description here

In Windows 7 when I wanted to switch between connected displays I typed Win+p.

3 Answers 3

0

It's not clear from your question that you know that you can toggle monitors on and off using the "on" slider in the "Displays" dialog you show. This is the standard way of enabling and disabling monitors in Gnome Shell.


You can create a quick key combination to toggle your monitors by using this script on github that was designed exactly for this purpose (see this article for more information). Copy the script and place it in your home directory. Make it executable by

chmod +x ~/toggle.sh

You can then bind this script to a custom keyboard shortcut using the keyboard system settings dialog. Click on the "Shortcuts" tab and then "Custom Shortcuts" in the left panel. Click the "+" sign to add a new shortcut and fill in the dialog like so:

Custom Shortcut

Click "Apply" and then click on the "Disabled" word and press the key combination you want to map to toggling monitors.

3
  • this is what i want, sadly it doesnt work properly..
    – Nir
    Jun 28, 2013 at 21:19
  • Does it work if you just run the script from the command line?
    – drs
    Jun 28, 2013 at 21:33
  • the script runs but it doesnt do what i wanted. anyway i change it a bit and now it works(one case the tv off and the monitor on and one case just the opposite), thanks!
    – Nir
    Jun 28, 2013 at 21:51
0

Disabling one of the displays will make the other active by default.

5
  • is it able by a button click?
    – Nir
    Jun 28, 2013 at 19:18
  • A few, yes. Look in the Monitors preferences. Jun 28, 2013 at 19:19
  • in 'displays' there isnt preferences.
    – Nir
    Jun 28, 2013 at 19:38
  • See the little slider that says "ON"? It's disabled because the other display is off. Turn that one on and this one off. Jun 28, 2013 at 20:36
  • i want to do it by keyboard click
    – Nir
    Jun 28, 2013 at 21:17
0

If you go under System -> Preferences -> Monitors you should get to a dialog like this:

         ss of monitors dialog

You can configure your monitor setup through here. I usually check the "Show monitors in panel" and you'll get a little applet in the panel from which you can switch between the monitors.

          applet in panel                                     menu pulled  down

If you have multiple monitors they'll show up in the dialog along with the pulldown in the panel.

1
  • no 'monitor preferences' in fedora 18, and no 'show monitors in panel' on 'displays'
    – Nir
    Jun 28, 2013 at 19:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .