3

It may be a silly question but in Windows I used ShiftAltTab to switch back between my open windows, that is go back to previous windows.

Unfortunately, it is not working in Gnome. I have even used AltTabLeft but with no success.

So how can I do the same in Gnome on RHEL6?

2

Sounds like something potentially with your keyboard or your installation. I use both of the following in Gnome:

  • Alt+Tab to cycle from left to right
  • Alt+Shift+Tab to cycle from right to left

This article is Ubuntu specific but should be applicable to your situation on RHEL6 non the less.

gconf-editor

Double check that the preferences are set so that moving right to left is configured correctly for the key combo mentioned above:

   ss of gconf-editor

  • It was disabled there, I made it <Alt><Shift>Tab, but still it didn't work. I changed the keyboard layout (language) switch shortcut from Alt+Shift to Ctrl+Shift as were suggested in the comments in the link you provided, I don't know how they can be related but it started to work. – easl Jun 27 '13 at 11:30
  • And now, ironically enough, ctrl+shift+tab to switch back between browser's tabs stopped to work :) – easl Jun 27 '13 at 11:30
1

For anyone using a more modern version of GNOME, here's what I have done.

I am using vanilla GNOME 3 on Ubuntu 18.04 (that is installing the base version of GNOME not the Ubuntu modified version). I think vanilla GNOME is the same as what RHEL uses too - at least that's what Fedora uses, so the following should work across those systems.

GNOME has two concepts for tabbing - tabbing between applications (the default) and tabbing between windows. Tabbing between applications groups the windows for that application together. I prefer (or at least I am more used to) tabbing between windows (and combined with Alt+Shift+Tab to go backwards).

In GNOME 3 at least this can now be fixed by just configuring the keyboard shortcuts.

  1. Go to the regular Settings > Devices > Keyboard > Navigation section.
  2. Disable both 'Switch applications' and 'Switch windows'
  3. Now neither Alt+Tab nor Super+Tab should work. Possibly do a log out/restart in between (I can't remember)
  4. Re-enable 'Switch windows' to be Alt+Tab.

I found that if both 'Switch applications' and 'Switch windows' were enabled then somehow Alt+Tab would still end up switching applications. This at least should be a solid method for guaranteeing that the Alt+Tab works as expected. You can then experiment setting 'Switch applications to Super+Tab.

This is what my keyboard shortcut settings looks like, note the 'Switch applications' at the top and 'Switch windows' at the bottom:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.