1

My left arrow key is not working as intended.

In KDE, it mutes the sound.

In Awesome Window manager, it does nothing.

Here's my 00-keyboard.conf file : I have tired to comment out XkbModel, XkbLayout and XkbVariant options too but no good

#This file was generated by the Anaconda installer
Section "InputClass"
        Identifier  "keyboard"
        MatchIsKeyboard "on"
        Option         "XkbModel"   "evdev"
        Option         "XkbLayout"     "us,ara"
        Option         "XkbVariant"    ",qwerty_digits"
        Option          "XkbOptions"    "grp:alt_shift_toggle,terminate:ctrl_alt_bksp,"
EndSection

Section "ServerFlags"
        Option  "DontZap" "false"
EndSection

Here's my .Xmodmap file (notice that the left arrow is not working with or without the xmodmap :

keycode 113 = 0x1008FF12 (the actual mute button)
keycode 224 = 0x1008FF03 (lowering brightness button - not working too)

Any help would be appreciated. this is really strange. I'm using Fedora 18.

3
  • Ok, the keycode 113 according to showkey is the f11 key which also is a multimedia key (Mute). So i tried to map it to the sound mute functionality. But when i press it, nothing happens. What happens In KDE, when i press the left arrow, mute functionality gets activated. (and i just did xmodmap .Xmodmap so when i restart X, it should be restored to defaults - which is, the left arrow key moves the pointer to the left, and the multimedia button has no functionality yet) Commented Jun 26, 2013 at 12:59
  • @don_crissti Ah, that did it, the left key was actually 113 and the mute key was 121. corrected it and the left key works, but still the mute key doesn't work. Commented Jun 26, 2013 at 13:34
  • @don_crissti I've worked it out, I needed xbindkeys to assign what XF86AudioMute do. Thanks for your help Commented Jun 26, 2013 at 14:06

1 Answer 1

2

You can try to see if the key gives the expected keycode with xev and pressing the key to see the actual keycode it generates. I have seen 'working' keyboards that had some fluid spilled over them generate wrong (and multiple) keycodes.

It looks like you are in 'us' mode with your keyboard. On that my generates keycode 113, so the muting does not seem be completely unexpected given your .Xmodmap.

Make sure to restart X (logout of the Windowmanager and log back in), to make sure changes to .Xmodmap take effect.

6
  • Hmm, that's strange, when i try using showkey the left arrow gives me 105 and the actual mute button gives 113 Commented Jun 26, 2013 at 13:02
  • Ok i tried with xev. The left arrow key gives me 113 and the mute key gives 121. I changed it in the .Xmodmap file, but unfortunately the problem still occurs. Commented Jun 26, 2013 at 13:10
  • I've worked it out, just restarted X and applied .Xmodmap after the modifications. Also i needed xbindkeys to assign what XF86AudioMute do. Thanks for your help Commented Jun 26, 2013 at 14:06
  • Sorry I should have included that you need to restart X if you change the .Xmodmap. I am going to add it so people don't have to wade through the comments. You can of course add an answer yourself as well with that info.
    – Anthon
    Commented Jun 26, 2013 at 14:26
  • 1
    @RafaelAdel Linux key codes shown by showkey and X key codes shown by xev are different. Also, you don't need to restart X after changing .Xmodmap, just reload it with xmodmap .Xmodmap. A few applications may need to be restarted if you've changed modifiers. Commented Jun 26, 2013 at 23:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .