5

I'm using Xubuntu 13.04 with xfce 4.10. I'm trying to entirely replace xfce 4.10 (not uninstall, but replace) with awesome. So far, I have yet to even get awesome to run.

The steps that I have tried thus far:

  1. Install awesome with sudo apt-get install awesome
  2. ~/.xinitrc now just contains exec awesome.
  3. mkdir ~/.config/awesome/ and cp /etc/xdg/awesome/rc.lua ~/.config/awesome/

I've tried restarting, I've tried just running awesome (I get E: awesome: main:445: another window manager is already running, which is expected, but I'd really like to start up my session in awesome, not have to manually quit xfce and then start awesome).

What am I missing?

1
  • Are you unable to simply select the session type from your display manager?
    – Joseph R.
    Oct 5 '13 at 9:01
2

I know this is not correct way to do it, but I just did:

cd /usr/bin ; mv xfwm4 xfwm4! ; ln -s awesome xfwm4

And restarted X.

1
  • That's actually kind of hilarious. Thanks for the response. :)
    – River Tam
    Jul 7 '13 at 20:20
0

There is a bug in the install. Pretty easy fix. Answer here: https://bugs.launchpad.net/ubuntu/+source/awesome/+bug/1094811

1
  • Welcome to Unix & Linux Stack Exchange! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – slm
    Aug 29 '13 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.