I got a Vodafone K3760 at some point in Debian/Lenny's lifetime, for use with a Lenovo S10e. I installed (from the Vodafone BetaVine site) usb-modeswitch 0.97 and vodafone-mobile-connect (VMC) 2.10.01-1 (or maybe it was actually vodafone-mobile-connect_svn20090615) and it all worked pretty well.

After the Squeeze update, I have had less luck. Unlike Lenny, Squeeze includes usb_modeswitch 1.1.4-2, and I also grabbed vodafone-mobile-connect 2.25.01. It does actually work... for a few minutes, then the system locks up (or sometimes the gnome panel dies, but xterms on-screen continue to work).

Anyone know what magic combinations of packages, if any, will work reliably with Squeeze ?

(The obvious next thing for me to try is to revert the relevant packages to their older versions; VMC does have quite a lot of dependencies though so I'm not too sure how well this will work).

There's another school of thought which says forget about Vodafone's app and just use the new Gnome network manager's mobile broadband support. I haven't tried this yet, but I kind of like the Vodafone app (for its usage monitoring, and for its access to SMS messages on the K3760; these are pretty important if you travel abroad and want to see what outrageous charges you'll be stung for if you dare connect). But if Gnome or other apps provide such functionality, I'd happily drop the Vodafone software.

Just to be clear: the system is rock solid when using wired or built-in Wi-Fi connection. Inserting the dongle seems to be pretty safe; the problems start once connected.

Update 1: I couldn't revert to the older Vodafone mobile connect because of various Python dependencies not in Squeeze. Reverting to the older usb_modeswitch seems to be possible, but at least this once I got a spew of kernel bug notifications (alas, these don't seem to submit anything useful: example) and got about 30mins uptime before a lockup. I'm not too sure what to make of dmesg (have got some saved); there are clearly some call stacks into serio_interrupt in i8042_interrupt in ...a pile of handle IRQ functions ... but there are other ones too.

Update 2: I managed to get a dmesg log of some kernel errors from the "all-squeeze" version (not using any modules from the older setup) before lockup. This can be found here; no idea how to interpret it myself.

  • 1
    I'm very tempted to ask you to try a younger kernel. – Tshepang Feb 28 '11 at 18:53
  • Thanks for the suggestion: I've just upgraded to linux-image-2.6.37-1-686 and linux-base (only) from sid, and yes it now seems to be working very well (not a hint of trouble in dmesg)... I'm posting this over 3G after some surfing; the crashy version would never have got that far. Not an entirely satisfactory solution (because by the time squeeze is retired, who knows what version wheezy/sid will have moved onto and whether upgrading will still be a viable option), but it certainly works for me now. Care to submit your previous comment as a formal answer so I can accept it ? – timday Feb 28 '11 at 22:57
  • Good to know I helped. Tell me, does the software that came with Vodafone (VMC) still work? Also, by all-Squeeze, do you mean that you are not using Vodafone's usb_modeswitch? – Tshepang Mar 1 '11 at 4:58
  • 1
    Yes, throughout the course of this investigation I've only been using VMC, not the Gnome network manager support for mobile broadband (might have been interesting to see whether it fared any better, but without VMC's SMS support and usage monitoring, it's not a complete solution like VMC). And yes by all-Squeeze I do mean using Squeeze's supplied version of usb-modeswitch. – timday Mar 1 '11 at 8:23
up vote 2 down vote accepted

Try a younger kernel, perhaps something from "sid" (aka Unstable).

  • Using the linux-image-2.6.37-1-686 and linux-base (only) currently in Sid seems to get the system working as expected. Thanks. – timday Mar 1 '11 at 8:25
  • Just tried the upgraded 2.6.32-31 in the Squeeze 6.0.1 update... but no improvement therer. So continued tracking sid's kernel to 2.6.38-1 and that's still working fine. – timday Mar 28 '11 at 20:31

I also asked this question on the Vodafone developer forums; interesting alternative answer there seems to confirm the issue and refers me to VMC's replacement Betavine Connection Manager (BCM), but that solution is untried by me yet.

  • Interesting forum there. Seems like yet another implementation of the SO concept? – Tshepang Mar 2 '11 at 5:54
  • 1
    It used to be hosted on the Betavine site and had a far more conventional format. Then late last year they migrated to the vodafone developer site and the new clearly SO-inspired style. But it's currently looking like a good example of what happens when an SO clone fails to achieve critical mass I think. – timday Mar 2 '11 at 9:32

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.