2

I'm using PuTTY with Windows to connect a remote Linux (Mint desktop) server. It's correct to forward Firefox, Banshee and other applications, however, when I want to use Google Chrome, it shows a message:

Created new window in existing browser session

And nothing happened. So, what could cause such a problem?

2
$ google-chrome --help
...
   --user-data-dir=DIR
          Specifies  the directory that user data (your "profile") is kept in.
          Defaults to ~/.config/google-chrome.
          Separate instances of Google Chrome must use separate user data
          directories; repeated invocations of google-chrome will reuse an
          existing process for a given user data directory.

You have an existing chrome process on a different display, and it's attaching to that process as it finds the existing data dir.

Specify a different user-data-dir for your forwarded display, eg.

$ google-chrome --user-data-dir=~/.config/putty-chrome &
  • this didnt work for me, im still seeing the same error i had, which is probably different from the OP issue. unable to load driver: swrast_dri.so. Im getting same error on chromium-stable also – Brian Thomas May 31 '17 at 0:56
  • I think you want to ask a new question, since this one is a) four years old, and b) nothing to do with your shared library driver. The ask question link is up the top, go for it! You might want to take a look at the help centre first too, there's useful information about asking good questions. – Useless May 31 '17 at 8:30
1

Firefox and Chrome have the limitation @Useless explained in his answer you cannot have multiple processes running with the same browser profile.

You can use the undocumented feature (at least it wasn't in my version's man page) to also get around this issue:

$ google-chrome --temp-profile

Reference

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.