4

I have my Apple Magic Trackpad connected to my Ubuntu 12.04 distro and it's working great with a custom xorg configuration file at /etc/X11/xorg.conf.d/60-apple-wireless-trackpad.conf:

# Configuration for fine-tuning only the Apple Magic Trackpad.
Section "InputClass"
    Identifier "Apple Magic Trackpad"
    Driver "synaptics"

    # Match only the Apple Magic Trackpad
    MatchUSBID "05ac:030e"
    MatchIsTouchpad "on"

    # Set resolution tweaks for better response
    Option "VertResolution" "75"
    Option "HorizResolution" "75"

    # Set a timeout for multi finger click so accidental double-clicks don't
    # happen when right clicking and other gestures
    Option "EmulateMidButtonTime" "100"

    # Increase sensitivity
    Option "MinSpeed" "1.75"
    Option "MaxSpeed" "1.85"
    Option "AccelFactor" "0.05"

    # Scrolling   
    Option "VertScrollDelta" "-100"
    Option "HorizScrollDelta" "-100"
EndSection

The negative scroll delta gives me "natural scrolling," ie reverse scrolling. The problem I'm having is that as I scroll, it will often "jump."

This is what happens:

  1. I two-finger drag to scroll down or up to a certain point.
  2. I then do the same action again quickly to continue scrolling
  3. The content jumps in the opposite direction of which I'm scrolling.

I've done a screen capture here. Watch it in full screen and pay attention to the scroll bar at left.

1

Looks to me like your "quick" scrolling is exceeding the scroll delta.

At any rate, I also have a Magic Trackpad on Ubuntu 12. I simply swapped the ZAxisMapping buttons to get natural scrolling.

Detailed instructions on the Ubuntu Wiki.

TL;DR:

Use xev to find the "swipe up" and "swipe down" buttons for your trackpad. Put them in reverse order in xorg.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.