2

With using caps lock for word capitalization, when I type fast using my Linux distro, I get the following:

CAps LOck NOt WOrking PRoperly.

I tried the same keyboard on a windows machine, it works properly. So, the main reason of the problem seems to be my Linux distro.

PS1: Same problem is also mentioned here: http://ubuntuforums.org/showthread.php?t=1462333 PS2: I use Ubuntu 13.04
PS3: Please do not give the advice to use shift instead of caps lock for capitalization purposes.

  • 3
    And have you tried the solution given in the thread? ubuntuforums.org/… The bug status is "RESOLVED/FIXED": bugs.freedesktop.org/show_bug.cgi?id=27903. – lgeorget Jun 23 '13 at 17:12
  • 1
    I'm able to reproduce the bug, even though I've never noticed it before. I'm using a Gentoo with xkeybord-config v2.7. – lgeorget Jun 23 '13 at 18:39
  • @lgeorget, It really worked. I was so angry to Ubuntu and apparently didn't read all the thread at the time I posted the question. Thanks. – Sait Jun 24 '13 at 8:14
  • 1
    If someone wants to properly answer the question, it may be of some help to others. I could do it, but I don't really understand the xkbcomp syntax, nor what the patch does exactly. Some explanations would be useful. – lgeorget Jun 24 '13 at 12:48
  • @lgeorget, If you choose answering it; I would happily mark as the answer. Thanks. – Sait Jun 24 '13 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.