3

I am attempting to use Fedora on a laptop with a broken screen connected to an external monitor. At what I assume is the login screen, I only see a solid grey screen. I am unable to log in because the computer is displaying the login box on the broken screen. Strangely, Fedora automatically mirrored the screens when I was booting from a live disk. Is there anyway I can change the monitor settings without logging in?

Extra information: Fedora 18 GNOME, lenovo ideapad U350.

1

Runtime Solution

One solution is to drop to a tty console (ctrlaltF2) and run xrandr to change the display settings to clone mode. Run the command once with no options to find the names of the connections. Look for a line that looks like

eDP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 282mm x 165mm

Here the connection is named eDP1. Set the working monitor to display the same content as the broken one with something like

xrandr --output eDP1 --auto --output VGA --auto --same-as eDP1

Then you can switch back to the graphical mode (ctrlaltF1) and the display should be cloned.


Persistent Solution

You can achieve a persistent solution by creating an xorg.conf file with the clone option set. Write the following lines to file and move it to /etc/X11/xorg.conf.d/20-clone-mode.conf

Section "ServerLayout"
        Option "Clone" "On"
EndSection

I haven't tested it, but if this configuration is complete, the monitors should be cloned the next time you boot.

  • I tried the first solution, and xrandr gave the message "can't open display." When I rebooted after trying the second one, the monitor shows nothing, and ctrl-alt-F2 does nothing. – Na'im Jun 22 '13 at 14:14
  • I see. I should have tried running xrandr outside of an X session; I can see now why that doesn't work. The behavior for the second solution is strange--even if something is wrong in 20-clone-mode.conf, you should still be able to access a console with ctrl-alt-F2. – drs Jun 23 '13 at 0:27
  • You can still gain access to your system by changing the boot target from the GRUB2 menu that shows right when you turn on your computer. See this answer unix.stackexchange.com/a/74088/34796. Once you boot into "multi-user" mode, you can delete the 20-clone-mode.conf file and you should be able to boot like you were before. If you're feeling ambitious, you can check the X logs in /var/log/Xorg.0.log.old for lines that near the end that are errors (containing (EE)) and we can try to figure out what was wrong with the configuration file. – drs Jun 23 '13 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.