I cannot boot the operating system on my laptop. I have three versions of the kernel installed and none of them will boot.

Booting into Windows (installed in a separate partition) still works, so I suspect the hardware is not at fault. I may have tried to update drivers before the problem occurred, so that could be the cause. I have also tried resetting the BIOS, to no effect.

I am using GRUB v1.99.

Selecting "Fedora (3.6.11-1.fc16.x86_64)" from the GRUB menu, the following is displayed:

Fedora (3.6.11-1.fc16.x86_64)
Loading initial ramdisk ...

Then I get the normal splash screen. But then it returns to the black screen with just the above two lines being displayed and hangs indefinitely.

Enabling verbose mode yields the following:

Fedora (3.6.11-1.fc16.x86_64)
Loading initial ramdisk ...
... (many lines - can transcribe if relevant) ...
Started Machine Check Exception Logging Daemon             [OK]
Started Install ABRT coredump hoot                         [OK]
Started Console Mouse manager                              [OK]
Started irqbalance daemon                                  [OK]
Started SSH server keys generation                         [OK]
Started Kernel Samepage Merging                            [OK]
Started Harvest vmcores for ABRT                           [OK]
Started ACPI Event Daemon                                  [OK]
Started Display Manager                                    [OK]
(hangs here)

No obvious errors are displayed - it just stops.

The grub config looks like:

setparams 'Fedora (3.6.11-1.fc16.x86_64)'

set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root='(hd0,msdos2)'
search --no-floppy --fs-uuid --set=root dd61afbf-2b76-44ab-b2ca-0e65f0664425
echo 'Loading Fedora (3.6.11-1.fc16.x86_64)'
linux /boot/vmlinuz-3.6.11-1.fc16.x86_64 root=UUID=dd61afbf-2b76-44ab-b2ca-0e65f0664425 ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrhebsun16 rhgb KEYTABLE=uk rd.luks=0 LANG=en_US.UTF-8
echo 'Loading initial ramdisk ...'
initrd /boot/initramfs-3.6.11-1.fc16.x86_64.img

/boot is in /dev/sda2; using a livedisk to inspect the directory yields the following:

cd /mnt/sda2/boot
ls -ld *
-rw-r--r--. 1 root root   119880 2012-08-15 17:01 config-3.4.9-1.fc16.x86_64
-rw-r--r--. 1 root root   122870 2012-12-17 16:33 config-3.6.11-1.fc16.x86_64
-rw-r--r--. 1 root root   122897 2012-10-31 23:53 config-3.6.5-2.fc16.x86_64
drwxr-xr-x. 2 root root     4096 2013-02-02 13:44 extlinux
drwxr-xr-x. 2 root root     4096 2011-12-03 11:22 grub
drwxr-xr-x. 3 root root     4096 2013-01-21 03:37 grub2
-rw-r--r--. 1 root root 17757091 2012-08-31 05:50 initramfs-3.4.9-1.fc16.x86_64.img
-rw-------. 1 root root 18065462 2013-01-21 03:37 initramfs-3.6.11-1.fc16.x86_64.img
-rw-------. 1 root root 18052180 2012-11-07 17:15 initramfs-3.6.5-2.fc16.x86_64.img
-rw-r--r--. 1 root root   593313 2012-01-16 17:29 initrd-plymouth.img
-rw-------. 1 root root  2444127 2012-08-15 17:01 System.map-3.4.9-1.fc16.x86_64
-rw-------. 1 root root  2497974 2012-12-17 16:33 System.map-3.6.11-1.fc16.x86_64
-rw-------. 1 root root  2496741 2012-10-31 23:53 System.map-3.6.5-2.fc16.x86_64
-rwxr-xr-x. 1 root root  4728480 2012-08-15 17:01 vmlinuz-3.4.9-1.fc16.x86_64
-rwxr-xr-x. 1 root root  4824784 2012-12-17 16:33 vmlinuz-3.6.11-1.fc16.x86_64
-rwxr-xr-x. 1 root root  4822224 2012-10-31 23:53 vmlinuz-3.6.5-2.fc16.x86_64

I'm not very good at sysadmin tasks, so I apologise if I am being stupid. However, I really cannot figure out what is going wrong - I would be incredibly grateful if anyone can help?


2 Answers 2


When you're in single user mode none of the network services are running. You can also append numbers instead of the "S":

  • 1 = Single Usermode
  • 3 = Network (no desktop)
  • 5 = Normal Desktop mode

I'd try 3 if you're trying to do updates to the internet. The computer should be fully usable except for no graphical desktop.

  • Running sudo yum update from userlevel 3 seems to have done it. I can now call startx without errors. I'll try restarting in runlevel 5 and see if it still works. Thanks!
    – Froskoy
    Jun 19, 2013 at 15:40
  • Just restarted and the result is quite weird. I get exactly the same problem as before, but if I first boot into runlevel 3, login and then type startx, everything works fine. Any ideas how I can get it to work fine without having to go through the intermediate step?
    – Froskoy
    Jun 19, 2013 at 15:43
  • Can you take a look at this thread? Do you have a Nvidia graphics card similar to the OP? If so then you likely need to make the change as he/she did to the /etc/X11/xorg.conf file.
    – slm
    Jun 19, 2013 at 16:58
  • Unfortunately, the problem persists even after making that change.
    – Froskoy
    Jul 1, 2013 at 12:00
  • @Froskoy - from what you've described I'm thinking it's an issue with gdm (GNOME Display manager). This seems to jive with where it's dying in the initial boot up logs. Also this would make sense given you can login in runlevel 3 and startx. Have you checked for any updates specifically the package gdm? I see a fair amount of issues around this pkg. w/ F16 through F18. Are using F16? You might want to consider moving up to a newer version or trying to update the gdm package specifically.
    – slm
    Jul 1, 2013 at 14:36

Have you tried booting into Single-User mode (edit the kernel line in grub's boot menu and append "S"). If that lets your system boot, it's your DM (as illustrated by the last line of your boot messages).

  • Thanks so much! That does give me a command prompt. When I type systemctl default, I get some lines of text (the final one of which is rpcbing[1378]: Cannot open '/var/lib/rpcbind/portmap.xdr' file for reading, errno 2 (No such file or directory)) and then it hangs again. How do I fix the Display Manager? Do I need to reinstall it?
    – Froskoy
    Jun 19, 2013 at 13:11
  • Looks like the DM is probably not the culprit. RPCBIND is used by networking - either your network is misconfigured or you're trying to do a network mount that's hanging the boot process. If you aren't using network filesystems, try disabling your network. Not sure how that's done on Fedora.
    – Mel Boyce
    Jun 19, 2013 at 13:22
  • I tried systemctl stop NetworkManager.service, followed by systemctl disable NetworkManager.service. I then did ^D to exit back into default mode, but now I just get two lines of text before it hangs: [30.389250] audispd[1110]: No plugins found, exiting [30.439426] abrtd[1111]: Init complete, entering main loop Any ideas?
    – Froskoy
    Jun 19, 2013 at 13:30
  • abrtd is a very Fedora-specific daemon - something to do with catching process crashes. If that's causing the problem, you could try disabling all of the abrt services. After some Googling, other Fedora folk seem to have similar problems to yours when messing around with display drivers - is that a potential source for you?
    – Mel Boyce
    Jun 19, 2013 at 14:35
  • Thanks for your reply. I did a system-wide update not long before the problem, so it's not impossible that display drivers are a potential source. Unfortunately stopping and disabling all the abrtd services only removes that final line in the above post - it does not stop the system from hanging :(
    – Froskoy
    Jun 19, 2013 at 14:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .