1

I am using SUSE Linux Enterprise Server 11 (x86_64) as VM Ware virtual machine (that was cloned). Not sure why but network card cannot be configured via yast2. If I go to edit and hit enter Yast will go back to "Control Center". Also in yast2 I can see that the card is "not connected". No idea what it means though.

But if I go command line and issue these two commands the network is up and running.

ifconfig eth1 10.0.0.xxx netmask 255.255.255.0 broadcast 10.0.0.255
route add default gw 10.0.0.1 eth1

From /var/log/messages

Jun 18 14:20:19 Edumate kernel: [  221.986998] e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Jun 18 14:20:19 Edumate kernel: [  221.988366] ADDRCONF(NETDEV_UP): eth1: link is not ready
Jun 18 14:20:19 Edumate kernel: [  221.988482] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Jun 18 14:20:29 Edumate kernel: [  232.399704] eth1: no IPv6 routers present
  • Q1: Would anybody know how to fix the network configuration or
  • Q2: What files I update with above two commands so I can have network up and running after each reboot?

EDITs

  • removing /etc/udev/rules.d/70-persistent-net.rules and rebooting didn't help

  • content of /etc/sysconfig/network

Edu:/var/lib/edu/bdrs # cd /etc/sysconfig/network

Edu:/etc/sysconfig/network # ll

total 108
-rw-r--r-- 1 root root 13192 Jun  5 16:30 config
-rw-rw-rw- 1 root root 13181 Jun  5 15:42 config.backup.by.convert_to_netconfig
-rw-r--r-- 1 root root  7482 Jun 18 14:10 dhcp
-rw-r--r-- 1 root root  7686 Jun  5 15:42 dhcp.backup.by.convert_to_netconfig
drwxr-xr-x 2 root root  4096 Jun  5 15:42 if-down.d
drwxr-xr-x 2 root root  4096 Jun  5 15:42 if-up.d
-rw------- 1 root root   172 Jan 31 23:45 ifcfg-lo
-rw-r--r-- 1 root root 29333 Jan 31 23:45 ifcfg.template
-rw-r--r-- 1 root root   239 Jan 31 23:45 ifroute-lo
drwx------ 2 root root  4096 May  6  2010 providers
-rw-r--r-- 1 root root    22 Jun 18 14:07 routes
-rw-r--r-- 1 root root     0 Jun 18 14:07 routes.YaST2save
drwxr-xr-x 2 root root  4096 Jun  5 15:42 scripts
  • What's in your /etc/network/interfaces? – tripleee Jun 18 '13 at 13:26
  • /etc/network directory doesn't exist on my system – Radek Jun 18 '13 at 22:45
  • Ok, what's in your /etc/sysconfig/network then? – ott-- Jun 18 '13 at 23:39
  • @ott: please see my Edits – Radek Jun 18 '13 at 23:56
  • @tripleee /etc/network/interfaces is on Debian and derivatives. On SuSE and Red Hat, these settings are in /etc/sysconfig/network/ifcfg-*. – Gilles Jun 19 '13 at 0:16
1

On SuSE, you can configure the network manually via files in /etc/sysconfig/network. Create a file called /etc/sysconfig/network/ifcfg-eth1 containing

STARTMODE=onboot
BOOTPROTO=static
IPADDR=10.0.0.xxx
NETMASK=255.255.255.0
BROADCAST=10.0.0.255

The default route needs to be set in /etc/sysconfig/network/routes.

default 10.0.0.1 - eth1
  • By doing so I am able to edit the network card in yast but after reboot the card is not up. – Radek Jun 19 '13 at 0:36
  • In yast I can see "activate device" at boot time setting to be on. – Radek Jun 19 '13 at 0:41
  • @Radek Sorry, I'd mixed up RH and SuSE. Try my edit. – Gilles Jun 19 '13 at 0:50
  • You're a genius. I can reboot and network is up then. Thank you so much. – Radek Jun 19 '13 at 1:10
  • One more thing. Could you by any chance explain what happened? Configuration got lost when cloning virtual machine? – Radek Jun 19 '13 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.