I have a D-Link DWM-156 HSPA modem, that I bought just a few days ago. The modem has drivers in its internal storage. There are Debian packages (.deb) for both i386 and amd64, so obviously I installed the amd64.deb using Software Center: 3g_modem_connect_D300_amd64.deb. Then I did:

sudo modprobe usbserial vendor=0x2001 product=0x7d01

I have confirmed that the device switched to usbserial mode from usb-storage mode, as the product ID was a706 before. Although there are no commands like usbdeviceswitchdlink after installation.

But here is the thing, the device is detected and I get the mobile broadband options in the network menu only when a SIM card is not present in the modem. If a SIM card is present, the modem switches to usbserial mode but after that, there is no change in the network menu. I can't use my modem in Ubuntu at all.


Well, this issue was fixed in Ubuntu 14.04. It also switches to USB modem mode automatically.

So, upgrading to 14.04 solved the problem.


I had had the same problem and have found a simple way to solve the issue. I have used the default usb_modeswitch itself to switch the storage mode to modem mode.

Double clicking will not install the .deb file for most of the users. So use dpkg command in terminal.

I have posted all the details with pictures so even beginers can easily solve the issue.


  • I have done all that. The modem switches from cdrom to usbserial mode. The product ID is 0x7d01. But its doesn't show up as a mobile broadband device when a SIM Card is present. It shows up only when there is no SIM Card. I have used multiple SIM Cards too. Same behavior. – Aneesh Neelam Jul 14 '13 at 8:43

Try sudo command along with usb modeswitch command. It worked for a couple of people. If mode switch is success and sim card inserted then try wvdial to connect, or try gnome-ppp it has more better gui, more satisfactory. Also definitly gives more options than default network-manager-gnome

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.