I deleted every partition on my system, even the partition on my USB stick. Then I created a partition with SliTaz which I'm currently on. But then I found out that my USB stick didn't get discovered if I plug it in.

So I made a new NTFS partition (on the USB stick of course) with GParted. Now I wanted to boot into another Linux OS, so I downloaded the iso(kali-linux), then copied it to the drive. But now I can't make it bootable, when I use the "make bootable in a linux os" installation guide from kali-linux, which says, do dd if=kali.iso of=/dev/sdb bs=512k (at first, the partition was at sdb1), and I got "no such file, directory"but I already renamed the file to kali.iso . Then I played around a bit and deleted again the usb partition and then made it an ext3 partition, FAT32 partition on finaly back to NTFS.

But nothing worked. When it was an ext3 partition and I wanted to copy files on the drive I got "permission denied"(but worked with root user in the console). But it never booted from the iso at startup. Now if I go into mountbox(SliTaz program for mounting), I get some weird things:

/dev/sda (232gb):

Umounted dev:

/dev/loop0p1 Hidden HPSF/NTFS Boot yes #What is loop0p1?
/dev/sda1/  System: Linux

Mounted fs:

/dev/sdc1 30gb Mounted on: /media/disk-1 #(should be usb stick, but the mounted folder was different at the beginning)
/dev/loop0 Mounted on: /media/cdrom read only

GParted shows:

/dev/sda1 Filesystem: ext2 #(this is SliTaz, everything is fine here, I think)

and 218gb of free memory, not "located"

/dev/sdc #at the beginning it was /dev/sdb I think, only sure that it was changed. :

/dev/sdc1 Filesystem NTFS  Mountpoint: /media/disk-1 Size 30gb

Output of fdisk -l is

Disk /dev/loop0: 2444 MB, 2444689408 bytes
146 heads, 32 sectors/track, 1022 cylinders
Units = cylinders of 4672 * 512 = 2392064 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/loop0p1   *           1        1022     2387360  17 Hidden HPFS/NTFS

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sda1               1        1913    15360000  83 Linux

Disk /dev/sdc: 31.2 GB, 31221153792 bytes
255 heads, 63 sectors/track, 3795 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sdc1               1        3796    30487552   7 HPFS/NTFS

If I use the SliTaz program to create a bootable USB stick I get: "unable to mount iso or to find a filesystem on it rootfs.gz"

So, how can I fix all this? How did this loop0 stuff come up and some letters changed down in the alphabet. And finally, how can I get my usb stick to be bootable with the iso?

Please no blame for kali-linux, I do tests and stuff on my own network or virtualised machines, and I like that many programming stuff that I use with python (gtk, pyside, scapy etc) is preinstalled there. My intention is to make a dualboot with Kali-Linux and SliTaz.

1 Answer 1


I have noticed flash drives dont like to be changed from their native fs. Rather use a tool to create a bootable flash drive, perhaps use a disk image? pendrivelinux has a whole bunch of different tools. Yumi is great for multi-oses and it supports persistence on some linux distros.

The mounting permissions problem probably has to do with what is auto-mounting your drive. If root mounts the drive initially a normal user wont be able to access it. Try umount as root to unmount the drive and then create a new folder as your user account (or use chmod -R 0777 your_folder_path) and remount to that folder as your user should fix the permissions problem.

  • Flash drives don't have such a concept of a "native file system", so I'm not sure what saying that they don't like to be changed from it is supposed to mean, since filesystems are completely transparent to the flash drive. Flash drives operate at the block level.
    – Chris Down
    Jun 17, 2015 at 16:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .