I was trying to upgrade my arch linux with pacman -Syu after having returned from vacation and now I get this error that I cannot quite make sense of:

(133/133) checking for file conflicts              [######################] 100%
error: failed to commit transaction (conflicting files)
filesystem: /bin exists in filesystem
filesystem: /sbin exists in filesystem
filesystem: /usr/sbin exists in filesystem
Errors occurred, no packages were upgraded.

do you have an idea what is wrong here? The arch linux installation is quite new so I did not expect any serious upgrade issues for some time...

1 Answer 1


Binaries have been moved to /usr/bin.

You need to approach the upgrade in two phases, as per the news article. First remove or update any packages from non-official repos, then update your system in three distinct steps:

pacman -Syu --ignore filesystem,bash
pacman -S bash
pacman -Su

If you encounter any difficulties, there is a long thread on the Arch boards with fixes.

To avoid this situation in future, you should subscribe to the ML or the RSS feed from the News page so you get advance warning of any significant changes that require user intervention.

  • 2
    These two commands might be usefull, too: grep '^\(bin\|sbin\|usr/sbin\)' /var/lib/pacman/local/*/files | cut -d ":" -f 1 | uniq | cut -d "/" -f 6 lists all packages that hold files in /bin, /sbin or /usr/sbin and find /bin /sbin /usr/sbin -exec pacman -Qo -- {} + >/dev/null lists all files in these directories that don't belong to any package.
    – Torben
    Commented Jun 17, 2013 at 20:04
  • @jasonwryan could you clarify why you specify filesystem,bash instead of just filesystem? I ran into this and solved it by just ignoring filesystem as that was the only thing mentioned in the error message and it worked fine.
    – Matijs
    Commented Sep 14, 2013 at 10:52
  • Those are the instructions from the developers. Also, if you b0rk the bash move, then you won't be able to boot (or do anything much at all)...
    – jasonwryan
    Commented Sep 14, 2013 at 20:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .