I'm trying to get X to work on a ThinkPad W530. I set the BIOS to only use the integrated graphics, I attempt to boot. The display goes blank when KMS is executed and does not recover.

I append nomodeset or i915.modeset=0. Then it does boot, does not attempt to change resolution while in console mode, but I cannot start X.

I see in dmesg:

[drm:drm_pci_agp_init] *ERROR* Cannot initialize the agpgart module.
DRM: Fill_in_dev failed.

I have the latest BIOS for my system, and I've tried the kernels: 3.7.2, 3.9.5 and 3.10-rc5. This is a Slackware 14.0 64-bit distro.

It seems that the i915 module cannot work when nomodeset is used, and that there is some bug which makes the display turn blank. Is there some way around this?


I am using i915 module on RHEL 6.4 . I had some problem with X in the begining. Instead of color, I was getting greyscale display. After setting NOMODESET kernel parameter in /etc/grub.conf file, everything worked fine and I am getting a color display.

SO i915 works with NOMODESET.

Thanks, Stany

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.