1

I downloaded the installer from the website. When I run it, I get the following error:

Your system has broken dependencies. This application cannot continue until it is fixed. To fix it, run "gksudo synaptic" or "sudo apt-get install -f" in a terminal window.

I tried both options. When tried to fix the broken packages in synaptic I get

Some packages could not be retrieved, do you want to proceed?

I said yes. Then

>E: Unable to correct missing packages
W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/t/tiff/libtiff5_4.0.2-1ubuntu2.1_i386.deb
  404  Not Found [IP: 91.189.92.201 80]
W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gnutls26/libgnutls26_2.12.14-5ubuntu4.2_i386.deb
  404  Not Found [IP: 91.189.92.201 80]
W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5.5.29-0ubuntu0.12.10.1_all.deb
  404  Not Found [IP: 91.189.92.201 80]
W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.29-0ubuntu0.12.10.1_i386.deb
  404  Not Found [IP: 91.189.92.201 80]
2

There are several layers of problems, and they have little to with skype. Any install/update of packages on your system could have triggered this.

If you put your browser to http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/ (url from the last error message without file name), you see that there now are different versions for libmysqlclient*0ubuntu0.12.10. So there is no problem with reaching the server (i.e. it is online), just with your own machine not being up to date.

Normally you should do a regular (daily e.g.) update of the view your machine has of which packages (and their versions) are available with:

sudo apt-get upgrade

the servers do not change that often that it is necessary to run that before every install, but it is a good practise to try and do so if there are problems.

After that run:

sudo apt-get install --fix-missing --fix-broken

and try again.

1

That problem typically occurs when your local package list cache is out of date. To update it, use apt-get update. After that, you should be able to install the dependencies via apt-get install -f.

  • I tried apt-get update, but was returned: E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied) E: Unable to lock directory /var/lib/apt/lists/ E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root? – Paul Elfish Jun 10 '13 at 4:34
  • Well, were you root? – jordanm Jun 10 '13 at 4:42
  • I think he means to say that you were not root, in other words you need to append sudo in front of the commands to become root. – daboross Jun 10 '13 at 6:53
  • I did append sudo; I think I made a typo. I tried again later and everything was fine. Skype has now installed successfully. Thank you. – Paul Elfish Jun 11 '13 at 4:50
1

It seems you have some broken packages .So to remove it , first try :

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get remove
sudo apt-get autoremove

This will cleanup your system and remove all the unmet dependencies. Now try using :

sudo apt-get update

Now try using :

sudo apt-get install "package name"

The dpkg error occurs due to 2 problems : 1) You must be using only "apt-get update" instead of "sudo apt-get update" 2) You try to use the installer multiple times that is you try to simultaneously install 2 files on the system.

However I suppose the above suggested method solves your problem , However the easiest way to install skype on linux mint is as follows : 1) Press windows button 2) Type mintinstall 3) The Linux Mint store will open . 4) Search for Skype and Install it .

I installed skype through the 2nd method and feels it is much easier than using command line (if you are a beginner) .

  • 1
    What dpkg error are you referring to? The messages in the OP come from apt not being able to retrieve specific files. You also really have to go through hoops to install multiple files simultaneously, because the package database gets locked by the process working on it. – Anthon Jun 10 '13 at 6:09
  • I was talking about the dpkg error which @5space mentioned in the comment. It is surely due to not having sufficient privileges . But one more dpkg error arises when we simultaneously try to install multiple files. – tusharmakkar08 Jun 10 '13 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.