3

I have a machine which suspends but does not resume under Linux, but resumes perfectly under Windows 7.

When I suspend (be it through pm-suspend or GUI), the suspend goes through, the power LED changes from solid to blinking, but after about 10 seconds it turns off completely. At the same time, USB devices plugged in stop receiving power (a smartphone stops charging).

Pressing the power button makes the power LED and the CPU fan turn on, but not the screen or anything else. Pressing the reset button afterwards starts a cold boot process.

Windows 7 installed on the machine suspends and resumes fine.

I have tried echo 1 > /sys/power/pm_trace && pm-suspend as mentioned in Ubuntu manual. I do get the magic number (after the cold boot), but it changes between boots and the hash never matches anything.

System configuration:

  • Intel Core i7-3770
  • ASUS P8Z77-I DELUXE (BIOS 0902)
  • No discrete graphics (using the GPU in the processor)
  • Samsung SSD 830
  • Seasonic S12II 430W Power Supply

I have tried the following OS, with exactly the same results:

  • Ubuntu 12.10
  • Ubuntu 13.04
  • Ubuntu 13.04 with the latest available mainline kernel
  • Fedora 18
  • Current Arch Linux

How do I debug this problem?

  • What graphics card do you have? Believe it or not, that could be relevant. – terdon Jun 10 '13 at 0:24
  • Updated the configuration. – Koterpillar Jun 10 '13 at 0:27
1

I have replaced the PSU with the one integrated in a Realan E-I7 case (120W with an external 12V AC/DC converter). This changed the behavior: after a few blinks, the computer resumes from sleep by itself.

Then I updated the motherboard BIOS to version 1101. This fixed the problem completely.

However, I still do not know how to debug any suspend-related problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.