I have a 2GB Micro SD card and a USB card reader. When I run lsusb I can see the card reader is recognized, but when I run lsblk I see no additional storage devices.

[lane@Lane-ArchSystem 19:38:08 ~]$ lsusb
Bus 001 Device 003: ID 041e:4069 Creative Technology, Ltd 
Bus 002 Device 002: ID 046d:c00e Logitech, Inc. M-BJ58/M-BJ69 Optical Wheel Mouse
Bus 002 Device 003: ID 0b38:0010 Gear Head 107-Key Keyboard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[lane@Lane-ArchSystem 19:38:13 ~]$ lsblk
sda      8:0    0  1.4T  0 disk 
├─sda1   8:1    0  1.4T  0 part /
├─sda2   8:2    0    1K  0 part 
└─sda5   8:5    0 1023M  0 part 
sr0     11:0    1 1024M  0 rom  
[lane@Lane-ArchSystem 19:38:17 ~]$ 

Not sure what the problem might be I've never run into anything like this before.

EDIT: Forgot to mention that I did have the SD card in the reader before I plugged it into the USB port.

  • Sorry I'm a little hectic at the moment, I just realized that I didn't have the card reader in when I copied the output from my terminal. Though the output wasn't any different from lsblk when I did have it plugged in. Here is the output from it now [lane@Lane-ArchSystem 19:38:17 ~]$ lsusb Bus 001 Device 003: ID 041e:4069 Creative Technology, Ltd Bus 001 Device 012: ID 05e3:0723 Genesys Logic, Inc. GL827L SD/MMC/MS Flash Card Reader – a_pen9uin Jun 10 '13 at 0:17
  • Can you add that output to the question? Is rather difficult to read from a comment. – Braiam Jul 23 '13 at 3:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.