0

I am trying to install MySQL-server-5.6.12-1.el6.i686.rpm on a Red Hat Enterprise 6.1 server.

I receive the following error:

rpm -Uvh MySQL-server-5.6.12-1.el6.i686.rpm
error: Failed dependencies:
        libaio.so.1 is needed by MySQL-server-5.6.12-1.el6.i686
        libaio.so.1(LIBAIO_0.1) is needed by MySQL-server-5.6.12-1.el6.i686
        libaio.so.1(LIBAIO_0.4) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6 is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.0) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.1) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.1.2) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.1.3) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.10) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.2) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.2.3) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.3) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.3.3) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.3.4) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.4) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.7) is needed by MySQL-server-5.6.12-1.el6.i686
        libc.so.6(GLIBC_2.8) is needed by MySQL-server-5.6.12-1.el6.i686
        libcrypt.so.1 is needed by MySQL-server-5.6.12-1.el6.i686
        libcrypt.so.1(GLIBC_2.0) is needed by MySQL-server-5.6.12-1.el6.i686
        libdl.so.2 is needed by MySQL-server-5.6.12-1.el6.i686
        libdl.so.2(GLIBC_2.0) is needed by MySQL-server-5.6.12-1.el6.i686
        libdl.so.2(GLIBC_2.1) is needed by MySQL-server-5.6.12-1.el6.i686
        libgcc_s.so.1 is needed by MySQL-server-5.6.12-1.el6.i686
        libgcc_s.so.1(GCC_3.0) is needed by MySQL-server-5.6.12-1.el6.i686
        libgcc_s.so.1(GLIBC_2.0) is needed by MySQL-server-5.6.12-1.el6.i686
        libm.so.6 is needed by MySQL-server-5.6.12-1.el6.i686
        libm.so.6(GLIBC_2.0) is needed by MySQL-server-5.6.12-1.el6.i686
        libm.so.6(GLIBC_2.1) is needed by MySQL-server-5.6.12-1.el6.i686
        libpthread.so.0 is needed by MySQL-server-5.6.12-1.el6.i686
        libpthread.so.0(GLIBC_2.0) is needed by MySQL-server-5.6.12-1.el6.i686
        libpthread.so.0(GLIBC_2.1) is needed by MySQL-server-5.6.12-1.el6.i686
        libpthread.so.0(GLIBC_2.2) is needed by MySQL-server-5.6.12-1.el6.i686
        libpthread.so.0(GLIBC_2.3.2) is needed by MySQL-server-5.6.12-1.el6.i686
        librt.so.1 is needed by MySQL-server-5.6.12-1.el6.i686
        librt.so.1(GLIBC_2.2) is needed by MySQL-server-5.6.12-1.el6.i686
        libstdc++.so.6 is needed by MySQL-server-5.6.12-1.el6.i686
        libstdc++.so.6(CXXABI_1.3) is needed by MySQL-server-5.6.12-1.el6.i686
        libstdc++.so.6(GLIBCXX_3.4) is needed by MySQL-server-5.6.12-1.el6.i686
        libstdc++.so.6(GLIBCXX_3.4.11) is needed by MySQL-server-5.6.12-1.el6.i686

I recognize that these are programs I need to install. My question is where should I look to download these programs to install or should I just look for an older version of MySQL?

EDIT: In the end it was actually a system architecture problem. System architecture should always be kept in mind when installing components in linux. I was using a i686 rpm when it was a x86_x64 system

1

You can use YUM rep which updated version of MySQL, as in here:http://www.webtatic.com/packages/mysql55/

1

It's highly recommended to use the packages that come with your distribution. RHEL 6.1 comes with 5.1.52, and you should use that.

Actually - you should think about updating the machine to a later level.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.