7

I have a web application which crawls data and any browser download it first the second one will not get that crawl informations.

While using Chromium-browser in a PC i start as below:

$ chromium-browser -kiosk "http://pbx/adminkiosk/index?language=EN&username=2002&password=1234" &
sun@sun-Alienware-X51:~$ ps aux | grep "chromium-browser"
sun      31816  0.7  1.5 613092 61384 pts/4    Sl   15:44   0:03 /usr/lib/chromium-browser/chromium-browser -kiosk http://pbx/adminkiosk/index?language=EN&username=2002&password=1234
sun      31818  0.0  0.1 264484  7248 pts/4    S    15:44   0:00 /usr/lib/chromium-browser/chromium-browser -kiosk http://pbx/adminkiosk/index?language=EN&username=2002&password=1234
sun      31819  0.0  0.0   6464   408 pts/4    S    15:44   0:00 /usr/lib/chromium-browser/chromium-browser-sandbox /usr/lib/chromium-browser/chromium-browser --type=zygote
sun      31820  0.0  0.4 281364 18012 pts/4    S    15:44   0:00 /usr/lib/chromium-browser/chromium-browser --type=zygote
sun      31824  0.0  0.1 281364  5404 pts/4    S    15:44   0:00 /usr/lib/chromium-browser/chromium-browser --type=zygote
sun      31849  1.1  2.3 1052972 91968 pts/4   Sl   15:44   0:05 /usr/lib/chromium-browser/chromium-browser --type=renderer --lang=en-US --force-fieldtrials=ForceCompositingMode/disable/InfiniteCache/No/OmniboxHQPReplaceHUPRearrangeNumComponents/Standard/OmniboxSearchSuggestTrialStarted2013Q1/5/OneClickSignIn/BlueOnWhite/Prefetch/ContentPrefetchPrefetchOff/Prerender/Prerender15minTTL/UMA-New-Install-Uniformity-Trial/Experiment/UMA-Session-Randomized-Uniformity-Trial-5-Percent/group_15/UMA-Uniformity-Trial-1-Percent/group_45/UMA-Uniformity-Trial-10-Percent/group_06/UMA-Uniformity-Trial-20-Percent/group_02/UMA-Uniformity-Trial-5-Percent/default/UMA-Uniformity-Trial-50-Percent/group_01/ --disable-gl-multisampling --disable-accelerated-2d-canvas --disable-accelerated-video-decode --channel=31816.0.281183995
sun      31981  0.0  0.0  13584   924 pts/4    S+   15:51   0:00 grep --color=auto chromium-browser

Now because 2 instance opening 2 url the data that gets crawled is delivered to other instance without balance. As a result my apps does not work with Chromium but works with Firefox/Opera.

How can i tell Chromium to stop this? And run the url only with one instance not twice??

EDIT:

I tried flags but no luck

--process-per-site  
--single-process
  • 1
    I don't understand all the ps columns, but I guess you should look at the difference between the two processes which is in the STAT column, the Sl and S. From the ps man pages, the l means multithreading (hyperthreading), which I think has to do with the kernel and how it deals with processors that have hyperthreading enabled. pthread and NPTL are keywords I found. This question might have some information for you. – Alaa Ali Jun 20 '13 at 8:20
  • @Alaa: the problem is very strange and nobody is understanding the real problem i think. 1) lets say a website every second refresh auto and have a counter how many time it was refreshed 100time? 2) instead of 100 time of real refresh you will see 200times it was refreshed 3) because its running as twice instead of once – YumYumYum Jun 20 '13 at 8:57
  • How many processes do you get if you just load www.google.com using chromium with the same command line? – EightBitTony Jun 21 '13 at 22:50
  • Why not use cURL or wget or PhantomJS – sparticvs Jun 22 '13 at 1:36
1

There are many explanations to why this may be happening.

I remembered Chromium is also auto-launching a GPU process (not on my laptop, though), and since you're using Alienware I suppose you have the GPU process "sleeping" with 0% use waiting for some graphics to display.

I suggest you try the following flags:

--disable-gpu-process-prelaunch --disable-software-rasterizer

to disable GPU (and extras)

or this flag:

--in-process-gpu

to run it as a thread

you can also try

process-per-tab

but it seems like you've tried something similar which wasn't of aid.

please report back with your findings :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.