9

From time to time (quite randomly), Nemo on my Linux Mint 14 Cinnamon starts looking like this enter image description here

When usually it looks like this: enter image description here

Restarting Cinnamon (Alt+F2, r, Enter) doesn't help, I need to log out, and then log on.

Can someone tell me,

  • (I guess, that something with X Window System had crashed. dmesg doesn't show anything.) how to diagnose, what really happened? (update: it seems it is gnome-settings-daemon crash)
  • how to restore the normal theme without logging off (which requires closing all programs)?
  • how to minimize frequency of such things?

Suspicious entries in xsession-errors.lob

[0x7f9590006068] main input error: ES_OUT_SET_(GROUP_)PCR  is called too late (pts_delay increased to 300 ms)
[0x7f9590006068] main input error: ES_OUT_RESET_PCR called
[0x7f9590006068] main input error: ES_OUT_SET_(GROUP_)PCR  is called too late (pts_delay increased to 1108 ms)
[0x7f9590006068] main input error: ES_OUT_RESET_PCR called

(...)

[h264 @ 0x7f95790fc160] Missing reference picture
[h264 @ 0x7f95790fc160] decode_slice_header error
[h264 @ 0x7f95790fc160] mmco: unref short failure
[h264 @ 0x7f95790fc160] concealing 1620 DC, 1620 AC, 1620 MV errors
[h264 @ 0x7f95790fc160] Missing reference picture
[h264 @ 0x7f95790fc160] Missing reference picture
[h264 @ 0x7f95790fc160] Missing reference picture

(...)

No such schema 'com.canonical.unity-greeter'

Suspicious entries in syslog:

Jun 13 01:03:45 adam-N56VZ kernel: [49764.694213] gnome-settings-[4198]: segfault at 188b2 ip 00007f2e46acf0a6 sp 00007fff8acb45d0 error 4 in libgdk-3.so.0.600.0[7f2e46a8c000+7c000]
Jun 13 01:03:52 adam-N56VZ gnome-session[4098]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11

(...)

Jun 13 01:40:59 adam-N56VZ laptop-mode: Warning: Configuration file /etc/laptop-mode/conf.d/board-specific/*.conf is not readable, skipping.

Update:

It seems, that the this behavior can be reproduced by killing gnome-settings-daemon. The question remains on how to restore it? Simply running it as user or root doesn't change anything, even with restarting cinnamon (Alt+F2, r, Enter).

And the hardest question: how to prevent it from happening? Since it is a crash I guess I'll need to follow the procedure with filing bug report. But who's fault it is? Gnome's or Cinnamon's? Or maybe some other component is at fault here?

  • 1
    Have a look at /var/log/syslog and ~/.xsession-errors and check if you find something suspicious. If X had crashed, you wouldn't see the window at all. Also check if gnome-settings-daemon is running. – Marco Jun 5 '13 at 17:56
  • Are you using the Intel i915 driver? – charlesbridge Jun 6 '13 at 11:06
  • @Marco Well, both the log files are sooo huge, it's really difficult to find anything in them. Espessialy in .xsession-errors (230 kB) - because there are no dates appended, so I really have no clue how old each entry is. Can you give me a hint for what I should look for? – Adam Ryczkowski Jun 13 '13 at 5:40
  • 1
    Open up a terminal and try to start it manually and check if it runs or seqfaults. You can start it as gnome-settings-daemon --debug to obtain more information about what might go wrong. – Marco Jun 13 '13 at 9:20
  • 1
    You might run into bug #706330. This is a bug in the theming engine unico and can be worked around by selecting a theme which uses a different engine, e.g. Adwaita: gsettings set org.gnome.desktop.interface gtk-theme 'Adwaita' and watch the log if gnome-settings-daemon seqfaults with this theme as well. – Marco Jun 13 '13 at 9:31
2

It seems that cinnamon-settings-daemon/gnome-settings-daemon is not running. You can put it in startup aplications to make sure it starts when you log in.

  • The issue I'm encountering is that cinnamon-settings-daemon does not exist as a command. Running it results in: The program 'cinnamon-settings-daemon' is currently not installed. You can install it by typing: sudo apt install cinnamon-settings-daemon -- however when I try to install it I'm getting cinnamon-settings-daemon is already the newest version (3.4.0-1~zesty0). The system was originally Ubuntu GNOME, with the cinnamon-desktop-environment installed on top of it. Any ideas? – Berislav Lopac May 24 '17 at 10:28
1

finally i got solution.

Simply open Startup Applications from Control Center, check the option MATE Settings Daemon or Cinnamon Settings Daemon (according to your Desktop Environment) and that’s it.

Now login again and problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.