I have configured an OpenVPN server with ethernet bridging using this howto and this page regarding ethernet bridging. The server is also running Samba, Apache and Webmin.

Linux klesk 2.6.32-5-amd64 #1 SMP Sun Sep 23 10:07:46 UTC 2012 x86_64 GNU/Linux

Distributor ID: Debian
Release:    6.0.7
Codename:   squeeze

The problem is that I cannot access the server from outside of the LAN. When I connect to the webmin or Samba share internally I have no problems. The configuration on the router has not been changed and is still correct. I have tried disabling the iptables firewall with the following commands (this has been restored already)

iptables -F
iptables -X
iptables -t nat -F
iptables -t nat -X
iptables -t mangle -F
iptables -t mangle -X
iptables -P INPUT ACCEPT

But still no connections from outside are allowed. I believe the problem lies with the network interfaces created for OpenVPN. When I check Webmin I get the following information:

enter image description here

Currently I have iptables setup as described in the ethernet bridging setup page of OpenVPN:

iptables -A INPUT -i tap0 -j ACCEPT
iptables -A INPUT -i br0 -j ACCEPT
iptables -A FORWARD -i br0 -j ACCEPT

To summarize, with the current setup, as shown in the screenshot and iptables settings, I am able to connect to the server from within the LAN (SSH, Apache, Webmin, Samba, they all work) but from outside of the LAN the server isn't accepting any connections.

  • It maybe missing a gateway address. – Raza Jun 4 '13 at 21:43
  • Thanks, that was it. The script provided by OpenVPN apparantly doesn't copy that part from eth0. – InFerNo Jun 4 '13 at 22:20

It maybe missing a gateway address. – Salton

Thanks, that was it. The script provided by OpenVPN apparantly doesn't copy that part from eth0. – InFerNo

  • Can you please elaborate on the answer? Where exactly is it missing in the script? I'm also having this problem... Thanks – mands Feb 6 '15 at 23:17
  • @mands the scripts on this page create a br0 interface. The script automatically sets up the IP address and netmask, but nowhere does it provide the gateway. This is what I had to do myself manually. I didn't edit the script. – InFerNo Mar 21 '15 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.