2

I am trying to set up network printing on my Linux Mint 15 (64 bit) system (dualboot with Windows 7). The printer is a Canon PIXMA MG5100 and is connected (via USB) to a computer running Windows XP. It was shared through the printer properties menu (Control Panel > Printers and Faxes) I was able to print to this printer from my computer in Windows 7.

Using system-config-printer, I've found the printer (by entering the internal IP of the XP computer as the 'host' when adding using the "Find Network Printer" option). I've tried to print a blank page to test it, but the printer simply tries to take paper from the rear tray (of which there isn't any). I want it to use paper from the cassette, but the printer won't do that.

I've tried setting all paper source related settings (in LibreOffice and the actual printer itself) to 'Cassette'. I've also tried re-adding the printer via the CUPS web interface (not sure if that's the right name for it) at http://localhost:631. I've done it using both smb and lpd in both interfaces. In the web interface, my printer isn't automatically detected, so I have to manually add it. The driver is "Canon PIXMA MG5100 - CUPS+Gutenprint v5.2.9"

Since I am able to get the printer to start printing, and since I got it working perfectly in Windows, I believe this could be related to Linux in some way. I just want the printer to use the cassette as the paper source.

Edit: Also, on the Windows XP computer, when it tries to use rear tray paper, a message appears that tells me to load paper into the rear tray. It also mentions that when paper that is not A4 or some other standard size will be taken from the rear tray. This shouldn't be anything that could affect me since I'm printing in A4. It's not mentioned clearly, but it's possible that the printer might somehow be "thinking" that I'm not printing in A4.

  • Same stuff with Debian Stable and Canon PIXMA iP4600. Have you found a solution yet? – Michal Rus Jun 18 '14 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.