0

I have a computer connected via ethernet cables to my home router that preforms server like duties. Specifically, for some time I was running rtorrent on this machine. I wish I knew when this started to occur (then I could try and associate the break with an event), yet mysteriously all of my active torrents suddenly failed to seed or download. The program error message read Tracker: [Failed sending data to the peer].

My first attempt at troubleshooting was to completely uninstall and reinstall rtorrent. I rewrote (read: uncommented the example) my config files and started clean. The first torrent file in erred with the same message. I am familiar with the common key sequences to fix torrents that go rogue in rtorrent: C-d, C-k, C-e, C-r, C-s and many variations on the same, none of them proved fruitful.

Next up the operating system. I formatted a rather poorly maintained Linux Mint install and wrote it over with a fresh command-line Ubuntu installation. Feeling sure that I had nuked the issue I installed rtorrent only to once again be greeted with [Failed sending data to the peer].

If my thinking is logical the next step would be to investigate the connection between the machine and the router. However I am not really sure how to do that (only an amateur with network engineering) or what to analyze/check or even how to start. Any recommendations for how to proceed? Also if you need any specifics about the setup to offer advice, just ask and I will post links to config files or other information.

Extra Info: I can successfully download torrents from other machines on the same subnet.

Edit 1: I've verified something suspicious about the machine in question. When it is requested to ping www.google.com it replies unknown host If I discover google's public IP on a different computer (same subnet!) and then using that information request the faulty machine to ping 74.125.239.131 instead it succeeds. Could this DNS issue (that's what it is right?) be affecting the torrent protocol?

3
  • 1
    Have you established that your ISP isn't blocking P2P traffic? Have you tried changing ports?
    – jasonwryan
    Jun 4, 2013 at 1:28
  • I have tried changing ports, initially I was using a block in the 6000 range, now I'm in the 50000s. I am currently running the ISP P2P test, but I think that it is unlikely to be the case. I believe this because I can torrent from other machines on the same subnet.
    – Kaya
    Jun 4, 2013 at 2:33
  • I'd try a different client just to confirm whether it's the setup of the computer itself or rtorrent. I use vuze, works well.
    – slm
    Jun 4, 2013 at 3:35

2 Answers 2

1

I agree with @jasonwryan, sounds like your ISP is potentially blocking you. You can use this online test to confirm if this is in fact the case. The service is called BitTorrent Test.

NOTE: This test requires that you have Java enabled as a plugin in your browser.

Screenshot of results page

Here's what the results page looks like after performing a test. A test includes both a download and upload.

ss of results page

3
  • The BitTorrent Test reported that my ISP does not limit my torrent bandwidth. How I wish this were the case: I'm sure it's just something stupid that I have overlooked.
    – Kaya
    Jun 4, 2013 at 2:53
  • Do you have any suggestions for testing BitTorrent from the command line? My rtorrent box only has a terminal.
    – sybind
    Sep 24, 2013 at 3:43
  • Check out this EFF article: eff.org/wp/detecting-packet-injection, might be helpful.
    – slm
    Sep 24, 2013 at 4:09
0

Okay, so apparently the issue comes down to be setting up my static IP address incorrectly for this computer. I had not prescribed a DNS server properly, and upon switching it back to dhcp my torrent client regained functionality.

I guess at this point if I have any more issues with this they could be focused at ubuntu.stackexchange. Thanks slm and jasonwryan for your assistance.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .