1

I'm using gnome under Arch Linux in my laptop with a 1920*1080 monitor on the left of it, I set the monitor as my primary display in GNOME and everything works fine after I log in. However, GDM displays my log-in dialogue on my lap-top screen every time, and I noticed that my monitor was set defaultly on the right side of my laptop. I searched and found someone said mouse's position may have effect, which did not work on me. Can anybody help?

1

I was running into the same issues with my desktop PC. I have a second screen attached to it, which in only use to view movies on and is really far from my computer and hard to see.

@don-crissti pointed out correctly that it is an issue with the xorg.conf. So I will write this up as an answer.

For me it was as easy as running the nvidia-settings agent again. Set up one screen as primary display and overwrite my existing xorg.conf.

The result is a configuration looking like this (only the relevent section shown here):

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SMBX2335"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 580"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-2: nvidia-auto-select +0+0, DVI-I-3: 1920x1080 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

So basically there are two steps to do:

  1. Setup your Display in the Monitor section.
  2. Refer to that Display in the Screen section.

Then reboot or restart your XServer to apply those new settings.

Hope that helps!

0

This is actually worked for me

GDM - Arch wiki says:

If you have your monitors setup as you like (orientation, primary and so on) in ~/.config/monitors.xml and want GDM to honor those settings:

cp ~/.config/monitors.xml /var/lib/gdm/.config/monitors.xml

Changes will take effect on logout.

Note: Wayland backend may be ignoring /var/lib/gdm/.config/monitors.xml file.


This has no effect for me

xrandr at login
If you want to run a script using xrandr that affects the login screen you must add a script in /etc/X11/xinit/xinitrc.d.
For example, to select automatically a external screen connected through HDMI:

#!/bin/sh
EXTERNAL_OUTPUT="HDMI1"
INTERNAL_OUTPUT="eDP1"
if (xrandr | grep $EXTERNAL_OUTPUT | grep " connected "); then
    xrandr --output $INTERNAL_OUTPUT --off --output $EXTERNAL_OUTPUT --auto
else
    xrandr --output $INTERNAL_OUTPUT --auto
fi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.