0

I was instructed to upgrade Debian 10 to Debian 12. After the upgrade, I noticed that the ssh.service was not working. Now I found out that no 'apt' commands work. I can't install anything. Here the result of the perl -v command:

perl:

/usr/lib/x86_64-linux-gnu/libcrypt.so.1: version `XCRYPT_2.0' not found (required by perl)

and

ls -l /usr/lib/x86_64-linux-gnu/libcrypt.so.1:

/usr/lib/x86_64-linux-gnu/libcrypt.so.1 -> /usr/lib/x86_64-linux-gnu/libcrypt-2.28.so

The apt --fix-broken install command also does not work

Edit: This is my /etc/apt/sources.list file:

deb http://deb.debian.org/debian/ bookworm main

deb http://security.debian.org/debian-security bookworm-security main

deb http://deb.debian.org/debian/ bookworm-updates main

This is a good way?

Please help and best regards

New contributor
Szymon Tesmer is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

1 Answer 1

0

You need to upgrade libcrypt1. Since apt doesn’t work, try

wget http://deb.debian.org/debian/pool/main/libx/libxcrypt/libcrypt1_4.4.33-2_amd64.deb
sudo dpkg -i libcrypt1_4.4.33-2_amd64.deb

If wget doesn’t work, download the file on another computer, and copy it to the broken system.

I’m guessing you tried to upgrade directly from Debian 10 to 12; that’s not supported, you need to upgrade to 11 first. (It’s too late for you now, you need to finish the upgrade to 12.)

2
  • wget worked. The file downloaded and installed. However, I don't see, any improvement for the better. Still the same errors. Commented Jul 10 at 13:29
  • OK, I thought this was an instance of this known issue when upgrading from 10 to 12. Could you update your question to show the output of ldd /usr/bin/apt? Commented 2 days ago

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .