4

man iwconfig states:

   power  Used to manipulate power management scheme parameters and mode.
          To set the period between wake ups, enter period `value'. [...]
          Examples :
               iwconfig eth0 power period 2
               iwconfig eth0 power 500m unicast
               iwconfig eth0 power timeout 300u all
               iwconfig eth0 power saving 3
               iwconfig eth0 power off
               iwconfig eth0 power min period 2 power max period 4

It happens that at least with my three wireless cards (a Ralink and two Atheros) none of those commands work, except for iwconfig {interface} power {on|off}.

The rest of them always return:

Error for wireless request "Set Power Management" (8B2C) :
    invalid argument "{whatever I wrote}".

On the other side, iw help only reveals these options:

    dev <devname> set power_save <on|off>
            Set power save state to on or off.

    dev <devname> get power_save <param>
            Retrieve power save state.

Is it possible to set the polling interval for wireless power saving on Linux? In case it's possible, how to?

  • Can you provide specific model #'s on these cards? Also which Distro are we dealing with here? These types of features it's going to come down to...(1) certain models offer the feature and (2) certain combinations of a model w/ driver will work. Assuming that it's even possible. – slm Jun 2 '13 at 21:06
  • ID 14b2:3c22 Ralink Technology, Corp. Conceptronic C54RU v3 802.11bg Wireless Adapter [Ralink RT2571W] | Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01) | Atheros Communications Inc. AR9285 Wireless Network Adapter. Arch Linux with all of them. – Alicia Jun 2 '13 at 21:16
3

I think you're out of luck. These features do not work on my wifi Atheros cards either.

Ralink Tech. C54RU

I researched your Ralink Tech. card (14b2:3c22), it looks to be using this driver (rt73usb). It's listed on this nice Debian page that shows which devices are supported by each of the drivers. If you check out that page you'll see a link to the entire rt2x00 set of drivers.

If you go to that page and search for "power" you'll find 3 pages, the 3rd result is a log from a IRC meeting among the developers, dated: December 19, 2010. In the thread there are several references to power, specifically save in which one of devs states:

on recent rt2x00 git kernel, the device seems to work fine, although I think it will never sleep or use otherwise the powersaving functions

Additionally in one of the rt2x00 forums I found this thread titled: rt73 in AP mode: powersave support, set_tim() missing. Looking through this thread there were several patches submitted but it's unclear what the state of the support of these features is within the rt73 driver.

Atheros AR9227

For this card you might be in luck. I found this page off of the wireless.kernel.org site with this section: Dynamic power save. I think part of your issue is the power_save feature may be disabled on your card to start. It looks like you can turn it on with this command:

iw wlan0 set power_save on

And then tune it with this command:

iwconfig wlan0 power 500m

The other commands you asked about might work for you as well, once it's enabled. If enabling it works, you can probably make it permanent when the atheros kernel module/driver loads, but I'm not 100% how to accomplish that specifically.

You can usually pass parameters to the kernel modules when they're loading. Look around the wireless.kernel.org site for more on that. Post back if you get stuck.

References

  • iw wlan0 set power_save on is (AFAIK) the same as iwconfig wlan0 power on, which I tried before. That one works, but after trying iwconfig wlan0 power 500m again it outputs (one more time): Error for wireless request "Set Power Management" (8B2C) : SET failed on device wlan0 ; Invalid argument. (tried with an Atheros card) – Alicia Jun 3 '13 at 5:11
  • @ntrrgc - agreed, I kind of figured it was the same, I'm only going on the documentation I was able to dig up. So I would assume that neither of these cards support this particular feature. I've not had any WIFI Nics support this feature either. – slm Jun 3 '13 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.