4

I'm running KDE on Arch-Linux 64b.

I've been a Vim user for two years now, and I want to try learning Emacs - just so I can have a justification when I diss Emacs users. So far, my main problem with Emacs is that it many of it's shortcuts use ctrl+alt and ctrl+shift - so they collide with my global shortcuts.

I have no desire to change my global shortcuts(to what? Emacs leaves no key combination unbound...), but I can afford to disable them while the Emacs window has the focus.

So - can it be done? Can I disable the global shortcuts only when a specific application is running?

4

right-click on the emacs window titlebar, then:

More Actions ->

Special Application Settings ->

select tab Appearance & Fixes ->

check Ignore global shortcut, select Force from the dropdown menu and check the radio button Yes. enter image description here

You can access all your custom application settings via System Settings, selecting Window behaviour and then Window rules

  • It works, though I had to use "special window settings" rather than "special application settings". However, it does not ignore my keyboard layout switching shortcut - Alt+Shift. Is there any way to ignore it as well? – Idan Arye Jun 15 '13 at 18:19
  • @IdanArye "special window" applies to the current window only (the one from which you right-clicked), while "special application" applies to all windows related to a specific app, including open file dialog, setting dialog, etc. You may need to completely restart the app (every instance) for the "special application" setting to work. For the keyboard setting, how did you set it? If it is shown in the global shortcut config dialog it should be bypassed as well – Nico Boni Jun 15 '13 at 19:04
  • The "special window" worked and the "special application" didn't."special window" also has matching, so it still works whenever I reopen Emacs. As for the layout switching - I can't set it via the global shortcuts, since it involves only modifier keys(Alt+Shift) and the global shortcut mappings must have at least one regular key. I had to set it via "Input Devices"=>"Keyboard"=>"Layouts" – Idan Arye Jun 15 '13 at 23:43
  • I was just explaining the difference between the two. I'm not sure why the latter doesn't work for you, it works here (kde 4.11). If your keyboard shortcut is not listed in the global shortcut list it will not be bypassed, you have to change it to something that can be listed as a global shortcut. – Nico Boni Jun 16 '13 at 12:00
  • Oh. Well, I'm not gonna change my keymaps(that was the whole point of this question...), but thanks anyways! – Idan Arye Jun 16 '13 at 20:21
0

The inability to timely toggle global shortcuts is painful, especially when all of the sudden things happen that shouldn't when working from muscle memory. After digging in plasma manual I found:

Ignore global shortcuts

[blablabla...] or by running kcmshell4 keys in konsole while the window is active.

Now you need to bind this to a global shortcut ;-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.