I'm trying to mount an old NRG image file in my Arch Linux box. In Windows 7 I can mount it using PowerISO without problems.

When I try to mount it in Linux I get the following error messages:

$ sudo mount -o loop file.nrg folder/
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or helper program, or other error

In some cases useful info is found in syslog - try
dmesg | tail or so.

dmesg gives me the following output:

$ dmesg | tail
[103618.787063] EXT4-fs (loop0): VFS: Can't find ext4 filesystem
[103618.787129] EXT4-fs (loop0): VFS: Can't find ext4 filesystem
[103618.787185] EXT4-fs (loop0): VFS: Can't find ext4 filesystem
[103618.788898] ISOFS: Unable to identify CD-ROM format.

If I check for the file type of the image:

$ file file.nrg 
file.nrg: AIX core file fulldump 32-bit 64-bit

How can I mount this image in Linux?

  • It gives me the following error: mount: file.nrg: failed to setup loop device: Invalid argument – Peter Rabbit Jun 2 '13 at 11:11
  • "poweriso" is not available I tried "Furious ISO Mount" and it works – Amartya Jul 30 '15 at 15:03

Install nrg2iso , convert and mount the iso.

|improve this answer|||||
  • I already tried, it gives the same error I described in the question. – Peter Rabbit Jun 2 '13 at 11:18

There is also AcetoneISO. It's covered pretty well over here in this article.


   ss of acetoneiso

Issues with mounting

If you get the following error:

Error, could not mount image.

Then you most likely have an NRG file that isn't in the ISO9660 format. AcetoneISO cannot deal with these variants.

NOTE: See the NRG wikipedia page for more details on this file format. But I'll say it here, this is a proprietary format that the Nero Burning ROM software could write out, these aren't ISO files.

Your options become limited at this point. Under Linux you should be able to mount the .nrg file using a tool such as CDex. It should be in your distro's repos. Also the CDEmu Wikipedia page has a good list of the format's it supports and a good overview on the application.

If you need to mount/unmount these frequently this tool might also be helpful, cdemu-tray.

                        ss of cdemu-tray


The iat tool has no switches but looks like it can convert various CDROM formats to ISO. It was available in the Ubuntu/Debian repositories. It's pretty easy to use since it has literally no command line switches.

iat my.nrg output.iso


It's unclear whether FuseNRG can deal with the non iso9660 type of NRG files. But might be worth trying. FuseNRG makes use of fuseiso, looking at their wiki it's unclear there as well.

What else?

If none of these options work there was a method discussed in this launchpad thread titled: Howto convert file .nrg to .iso. The method called for using dd to carve out of the NRG file the actual data portion that is the contents of the ISO file. This sounded a bit drastic to me but might prove workable for you.

The #8 comment in that thread by a user named Tom Hansen gives good details on how to do this method. The method makes use of the fact noticed by him:

it appears that an .NRG file has 300KB (75x4096) = 307200 bytes pre-pended to the ISO image.

Assuming your file has this same characteristic the method goes on like this:

mkdir /media/loop_cd
mount -o norock,map=off,loop,offset=307200 imagefile.nrg /media/loop_cd

If this works then your NRG files can be converted to ISO files, using this method:

dd if=imagefile.nrg of=isofile.iso bs=4096 skip=75

See Tom's post for more details on this technique.

|improve this answer|||||
  • I get an error when trying to mount the NRG image: Error, could not mount image. – Peter Rabbit Jun 2 '13 at 11:56

Install the poweriso package:

# pacman -S poweriso

Convert the image to ISO:

$ poweriso convert file.nrg -o file.iso

Mount it:

# mount file.iso folder/

|improve this answer|||||
  • The poweriso package moved to the AUR. – not-a-user Oct 26 '17 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.