2

I have Debian bullseye

18:14:08 $ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 11 (bullseye)
Release:        11
Codename:       bullseye

But it seems that I have much of PHP from Debian buster:

18:18:51 $ apt list '?narrow(?installed, ?not(?origin(Debian)))'
Listing... Done
debsuryorg-archive-keyring/buster,now 2024.02.05+0~20240205.1+debian10~1.gbp343037 all [installed,automatic]
e2fslibs/now 1.44.5-1+deb10u3 amd64 [installed,local]
gcc-6-base/now 6.3.0-18+deb9u1 amd64 [installed,local]
gcc-8-base/now 8.3.0-6 amd64 [installed,local]
libapache2-mod-php8.3/buster,now 8.3.8-2+0~20240608.35+debian10~1.gbp4d7dbc amd64 [installed]
libapache2-mod-php/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
libapt-inst2.0/now 1.8.2.3 amd64 [installed,local]
libapt-pkg5.0/now 1.8.2.3 amd64 [installed,local]
libargon2-1/buster,now 0~20190702-0.1+0~20190710.3+debian10~1.gbp2fb167 amd64 [installed,automatic]
libcomerr2/now 1.44.5-1+deb10u3 amd64 [installed,local]
libcryptsetup4/now 2:1.7.3-4 amd64 [installed,local]
libdns-export162/now 1:9.10.3.dfsg.P4-12.3+deb9u12 amd64 [installed,local]
libffi6/now 3.2.1-9 amd64 [installed,local]
libgcc1/now 1:8.3.0-6 amd64 [installed,local]
libgd3/buster,now 2.3.3-9+0~20230207.13+debian10~1.gbp649015 amd64 [installed,automatic]
libgdbm3/now 1.8.3-14 amd64 [installed,local]
libhogweed4/now 3.4.1-1+deb10u1 amd64 [installed,local]
libicu65/buster,now 65.1-1+0~20200223.8+debian10~1.gbp519cf3 amd64 [installed,automatic]
libidn2-0/oldstable,now 2.3.0-5 amd64 [installed]
libip4tc0/now 1.8.2-4 amd64 [installed,local]
libip6tc0/now 1.8.2-4 amd64 [installed,local]
libisc-export160/now 1:9.10.3.dfsg.P4-12.3+deb9u12 amd64 [installed,local]
liblogging-stdlog0/now 1.0.5-2+b2 amd64 [installed,local]
libmpdec3/buster,now 2.5.1-2+0~20240210.5+debian10~1.gbp216c03 amd64 [installed,automatic]
libnettle6/now 3.4.1-1+deb10u1 amd64 [installed,local]
libpcre2-8-0/buster,now 10.40-1+0~20220713.16+debian10~1.gbpb6cec5 amd64 [installed,automatic]
libpcre3/buster,now 2:8.45-1+0~20230620.10+debian10~1.gbp8792c4 amd64 [installed]
libprocps6/now 2:3.3.12-3+deb9u1 amd64 [installed,local]
libreadline7/now 7.0-5 amd64 [installed,local]
libsodium23/buster,now 1.0.18-1+0~20191009.1+debian10~1.gbpb6823f amd64 [installed,automatic]
libssl1.0.2/now 1.0.2u-1~deb9u7 amd64 [installed,local]
libunistring0/now 0.9.6+really0.9.3-0.1 amd64 [installed,local]
libxml2/buster,now 2.9.14+dfsg-0.1+0~20230421.14+debian10~1.gbpf14485 amd64 [installed,automatic]
libzip4/buster,now 1.7.3-1+0~20210114.10+debian10~1.gbp4c125d amd64 [installed,automatic]
libzstd1/oldstable,now 1.4.8+dfsg-2.1 amd64 [installed,automatic]
linux-image-4.19.0-26-amd64/now 4.19.304-1 amd64 [installed,local]
multiarch-support/now 2.28-10+deb10u3 amd64 [installed,local]
php-bcmath/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php-common/buster,now 2:94+0~20240205.51+debian10~1.gbp6faa2e all [installed,automatic]
php-curl/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php-gd/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php-gmp/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php-imagick/buster,now 3.7.0-4+0~20231125.43+debian10~1.gbpbf7e27 amd64 [installed]
php-intl/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php-json/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php-mbstring/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php-mysql/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php-xml/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php-zip/buster,now 2:8.3+94+0~20240205.51+debian10~1.gbp6faa2e all [installed]
php8.3-apcu/buster,now 5.1.23-1+0~20231125.39+debian10~1.gbp8bf49a amd64 [installed]
[... more php 8.3 stuff ...]
php8.3-zip/buster,now 8.3.8-2+0~20240608.35+debian10~1.gbp4d7dbc amd64 [installed]
python-certbot-apache/now 0.31.0-1 all [installed,local]
python3-httplib2/oldstable,now 0.18.1-3 all [installed,automatic]

How would I upgrade all these from buster to bullseye? Ideally without losing my configuration. I recall that I had to modify php.ini for Nextcloud to work.

Why? Because I want to upgrade to bookworm and it says I should purge old packages

Okay, I was able to make everything else work with PHP 8.3 and I removed all old versions of PHP using

apt-get autoremove php7.0*
apt-get autoremove php7.3*
apt-get autoremove php7.4*
apt-get autoremove php8.0*
apt-get autoremove php8.1*

The issue still remains, just with fewer items in the list. PHP is still listed as 'buster'.

The output of apt-mark showhold is empty. apt-mark showmanual lists php and php8.3 packages.

0

1 Answer 1

4

While I edited the file /etc/apt/sources.list and changed everything from buster to bullseye there, I missed the file /etc/apt/sources.list.d/php.list. That one still said buster.

After changing stuff to bullseye there, I did apt update, apt upgrade and apt-get full-upgrade. All the buster references are now gone and the output of apt list '~o' as proposed by the upgrade guide is much shorter.

1
  • 2
    nice, very glad to hear this is a less daunting task than it looked like in the beginning! Commented Jun 22 at 18:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .