2

I was updating my system when I ran into an issue with the icu package breaking electron. I figured I would ignore updating this package for now and look into it later. After the update completed most applications can no longer run including pacman which errors with

error while loading shared libraries: libicuuc.so.75: cannot open shared object file: no such file or directory

After rebooting my system will no longer boot but I can access it with a recover drive. I'm not sure the best way to go about recovering my system, any advice?

3 Answers 3

3

According to the Arch Linux Wiki you should be able to perform maintainance on a (mounted) offline system using the ISO's pacman with the --root (or --sysroot) option.

From the ISO:

  1. Mount the broken system on /mnt
mount /dev/sdXY /mnt
  1. Mount some needed pseudo-filesystems:
mount -t proc /proc /mnt/proc/
mount -t sysfs /sys /mnt/sys/
mount --rbind /dev /mnt/dev/
  1. Try reinstalling icu and go from there:
pacman --root=/mnt -S icu

or

pacman --sysroot=/mnt -S icu
1
  • 1
    I think this method also would have worked! There is also --sysroot which does a similar thing.
    – Winnie22
    Commented May 26 at 21:51
2

I was able to get it resolved. On the ArchWiki there is a link to install pacman-static which doesn't require any libraries. You can install it with

curl https://pkgbuild.com/~morganamilo/pacman-static/x86_64/bin/pacman-static --output pacman-static

and then make it executable

chmod +x pacman-static

You then use ./pacman-static the same way you would use pacman

I was able to use this to uninstall electron22 which was causing the conflict with icu and then finish updating my system which resolved everything.

0

I had a similar problem by ignoring icc on upgrade (pacman -Suy --ignore icc). At some point of time, the computer froze and I had to restart it using hardware power button. At restart, it gave an error like lightDM failed to start. Solution: pacman-static did the trick to remove all electron instances (I had electron22 and electron27 installed. I removed the packages that depended on them like pycharm and sweethome3d). Then I used pacman-static to perform a full upgrade.

The process is as described on Winnie22 post. I only would add that no external drive or stick was need in my case. I logged into console #2 (using Ctrl+Alt+F2)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .