0

I just updated Jessie to Stretch now trying to move to Buster.

/etc/apt/sources.list

deb http://deb.debian.org/debian/ buster main non-free contrib
deb http://deb.debian.org/debian/ buster-updates main non-free contrib
deb http://security.debian.org/ buster/updates main non-free contrib

.

apt-get update
Ign:1 http://deb.debian.org/debian debian InRelease
Hit:2 http://security.debian.org buster/updates InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Ign:4 http://deb.debian.org/debian debian Release
Ign:5 http://deb.debian.org/debian debian/buster i386 Packages
Ign:6 http://deb.debian.org/debian debian/buster all Packages
Ign:7 http://deb.debian.org/debian debian/buster Translation-en_US
Ign:8 http://deb.debian.org/debian debian/buster Translation-en
Ign:9 http://deb.debian.org/debian debian/main all Packages
Ign:10 http://deb.debian.org/debian debian/main i386 Packages
Ign:11 http://deb.debian.org/debian debian/main Translation-en
Ign:12 http://deb.debian.org/debian debian/main Translation-en_US
Ign:13 http://deb.debian.org/debian debian/non-free i386 Packages
Ign:14 http://deb.debian.org/debian debian/non-free all Packages
Ign:15 http://deb.debian.org/debian debian/non-free Translation-en
Ign:16 http://deb.debian.org/debian debian/non-free Translation-en_US
Ign:17 http://deb.debian.org/debian debian/contrib all Packages
Ign:18 http://deb.debian.org/debian debian/contrib i386 Packages
Ign:19 http://deb.debian.org/debian debian/contrib Translation-en_US
Ign:20 http://deb.debian.org/debian debian/contrib Translation-en
Ign:5 http://deb.debian.org/debian debian/buster i386 Packages
Ign:6 http://deb.debian.org/debian debian/buster all Packages
Ign:7 http://deb.debian.org/debian debian/buster Translation-en_US
Ign:8 http://deb.debian.org/debian debian/buster Translation-en
Ign:9 http://deb.debian.org/debian debian/main all Packages
Ign:10 http://deb.debian.org/debian debian/main i386 Packages
Ign:11 http://deb.debian.org/debian debian/main Translation-en
Ign:12 http://deb.debian.org/debian debian/main Translation-en_US
Ign:13 http://deb.debian.org/debian debian/non-free i386 Packages
Ign:14 http://deb.debian.org/debian debian/non-free all Packages
Ign:15 http://deb.debian.org/debian debian/non-free Translation-en
Ign:16 http://deb.debian.org/debian debian/non-free Translation-en_US
Ign:17 http://deb.debian.org/debian debian/contrib all Packages
Ign:18 http://deb.debian.org/debian debian/contrib i386 Packages
Ign:19 http://deb.debian.org/debian debian/contrib Translation-en_US
Ign:20 http://deb.debian.org/debian debian/contrib Translation-en
Ign:5 http://deb.debian.org/debian debian/buster i386 Packages
Ign:6 http://deb.debian.org/debian debian/buster all Packages
Ign:7 http://deb.debian.org/debian debian/buster Translation-en_US
Ign:8 http://deb.debian.org/debian debian/buster Translation-en
Ign:9 http://deb.debian.org/debian debian/main all Packages
Ign:10 http://deb.debian.org/debian debian/main i386 Packages
Ign:11 http://deb.debian.org/debian debian/main Translation-en
Ign:12 http://deb.debian.org/debian debian/main Translation-en_US
Ign:13 http://deb.debian.org/debian debian/non-free i386 Packages
Ign:14 http://deb.debian.org/debian debian/non-free all Packages
Ign:15 http://deb.debian.org/debian debian/non-free Translation-en
Ign:16 http://deb.debian.org/debian debian/non-free Translation-en_US
Ign:17 http://deb.debian.org/debian debian/contrib all Packages
Ign:18 http://deb.debian.org/debian debian/contrib i386 Packages
Ign:19 http://deb.debian.org/debian debian/contrib Translation-en_US
Ign:20 http://deb.debian.org/debian debian/contrib Translation-en
Ign:5 http://deb.debian.org/debian debian/buster i386 Packages
Ign:6 http://deb.debian.org/debian debian/buster all Packages
Ign:7 http://deb.debian.org/debian debian/buster Translation-en_US
Ign:8 http://deb.debian.org/debian debian/buster Translation-en
Ign:9 http://deb.debian.org/debian debian/main all Packages
Ign:10 http://deb.debian.org/debian debian/main i386 Packages
Ign:11 http://deb.debian.org/debian debian/main Translation-en
Ign:12 http://deb.debian.org/debian debian/main Translation-en_US
Ign:13 http://deb.debian.org/debian debian/non-free i386 Packages
Ign:14 http://deb.debian.org/debian debian/non-free all Packages
Ign:15 http://deb.debian.org/debian debian/non-free Translation-en
Ign:16 http://deb.debian.org/debian debian/non-free Translation-en_US
Ign:17 http://deb.debian.org/debian debian/contrib all Packages
Ign:18 http://deb.debian.org/debian debian/contrib i386 Packages
Ign:19 http://deb.debian.org/debian debian/contrib Translation-en_US
Ign:20 http://deb.debian.org/debian debian/contrib Translation-en
Ign:5 http://deb.debian.org/debian debian/buster i386 Packages
Ign:6 http://deb.debian.org/debian debian/buster all Packages
Ign:7 http://deb.debian.org/debian debian/buster Translation-en_US
Ign:8 http://deb.debian.org/debian debian/buster Translation-en
Ign:9 http://deb.debian.org/debian debian/main all Packages
Ign:10 http://deb.debian.org/debian debian/main i386 Packages
Ign:11 http://deb.debian.org/debian debian/main Translation-en
Ign:12 http://deb.debian.org/debian debian/main Translation-en_US
Ign:13 http://deb.debian.org/debian debian/non-free i386 Packages
Ign:14 http://deb.debian.org/debian debian/non-free all Packages
Ign:15 http://deb.debian.org/debian debian/non-free Translation-en
Ign:16 http://deb.debian.org/debian debian/non-free Translation-en_US
Ign:17 http://deb.debian.org/debian debian/contrib all Packages
Ign:18 http://deb.debian.org/debian debian/contrib i386 Packages
Ign:19 http://deb.debian.org/debian debian/contrib Translation-en_US
Ign:20 http://deb.debian.org/debian debian/contrib Translation-en
Err:5 http://deb.debian.org/debian debian/buster i386 Packages
  404  Not Found [IP: 151.101.198.132 80]
Ign:6 http://deb.debian.org/debian debian/buster all Packages
Ign:7 http://deb.debian.org/debian debian/buster Translation-en_US
Ign:8 http://deb.debian.org/debian debian/buster Translation-en
Ign:9 http://deb.debian.org/debian debian/main all Packages
Ign:10 http://deb.debian.org/debian debian/main i386 Packages
Ign:11 http://deb.debian.org/debian debian/main Translation-en
Ign:12 http://deb.debian.org/debian debian/main Translation-en_US
Ign:13 http://deb.debian.org/debian debian/non-free i386 Packages
Ign:14 http://deb.debian.org/debian debian/non-free all Packages
Ign:15 http://deb.debian.org/debian debian/non-free Translation-en
Reading package lists... Done
W: The repository 'http://deb.debian.org/debian debian Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://deb.debian.org/debian/dists/debian/buster/binary-i386/Packages  404  Not Found [IP: 151.101.198.132 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

What am I doing wrong?

TIA!!

2
  • Does /etc/apt/sources.list exist on Debian Stretch? If so, then the path is not /etc/sources.list.
    – horsey_guy
    Commented May 18 at 6:21
  • Please edit your question to show the output of apt policy. Commented May 18 at 7:47

1 Answer 1

1

The error messages look as if your /etc/apt/sources.list (or /etc/apt/sources.list.d/*.list files, if they exist) still contained a mistyped repository URL or two. It looks like you might have had written debian in place of the release codename on one line, and debian/buster on another.

Please run cat -A /etc/apt/sources.list. It will make any normally invisible characters visible, so you'll be able to see if there are some extra characters within the repository configuration lines. Ideally, the only difference you should see is a $ character (indicating an end-of-line character) at the end of each line. If you find any other extra characters or other typos, fix them.

Then run apt-get clean. It will remove any cached repository metadata files from apt's local cache directories, guaranteeing that apt won't "remember" any earlier attempts with possibly wrong /etc/apt/sources.list contents. Then try apt-get update again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .