0

When running the native Linux GUI client megasync, it keeps on crashing every few minutes with my main backup folder.

Sometimes it takes a minute, sometimes half an hour, but eventually it crashes and gives the following output when you run it from the terminal:

Segmentation fault (core dumped)

I removed some files that could have been problematic (ended with a dot without any extension), I scanned the external drive the files are stored on with chkdsk on Windows (file system is exfat) and it still crashed.

I ran it with the --debug option turned on and looked at the generated log file, and there was nothing other than the same message.

For future reference, I'm putting here the command as I ran the process to create the log file (it adds the date to the log file name):

megasync --debug >> megasync-logfile-$(date +"%Y-%m-%d_%H-%M-%S").txt

For me it happened on Ubuntu 22.04, but I doubt it's distro-specific.

1 Answer 1

0

Apparently, there's an issue with the megasync client, and the best way to go around it (until it's fixed) is to run the client without thumbnail creation, from the command line:

megasync --nogfx

From GitHuB, there's a way to make this permanent during startup:

open ~/.config/autostart/megasync.desktop with a text editor, and change the line Exec=megasync to Exec=megasync --nogfx

In case the above doesn't work, then a possible solution may be relevant, from reading about the file count limit in mega.nz:

https://help.mega.io/plans-storage/space-storage/no-file-count-limit

It mentions that the more files you backup, the more memory the client consumes.

My backup machine had 8GB RAM, and 2GB local swap file. In addition, I had a single huge backup folder with a lot (too many) files in it.

I enlarged the swap file to 6GB (completely arbitrarily), and created several separate backup folders, rather than a single huge one.

Once I did that, there were still some occasional crashes every few hours, but this is something I can live with, and I would prefer not to raise the swap file size more than I already did.

2
  • That sounds like a horribly written client. Maybe use a different client program? Commented May 17 at 10:57
  • Thank you, @MarcusMüller, but I don't know of any alternative mega.nz client for Linux. I'm planning to start some correspondence with their Support, and I'll update this post once I have a definitive cause and solution.
    – bizna
    Commented May 20 at 6:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .