0

I am trying to install KDE Plasma 5 (for compatibility reasons) on Arch Linux (installed through EndeavourOS) without using pacman, as, from what I can tell, it is already updated to Plasma 6 and partial updates are bad. So I went with the Nix package manager, hoping that installed this way, I could keep it relatively isolated (if there are better ways, please let me know too).

I started with nix-env -iA nixpkgs.libsForQt5, hoping to install all the necessary packages, but I got a lot of warnings about broken or unsupported packages. So I downloaded all packages in there one by one (I also had to run nix-env --set-flag priority 0 akonadi-23.08.5 to get rid of conflicts at /share/mime/icons). In the end, I got this list of packages installed:

accounts-qml-module-0.7-unstable-2022-10-28
accounts-qt-1.17
akonadi-23.08.5
akonadi-calendar-23.08.5
akonadi-calendar-tools-23.08.5
akonadi-contacts-23.08.5
akonadi-import-wizard-23.08.5
akonadi-notes-23.08.5
akonadi-search-23.08.5
akonadiconsole-23.08.5
akregator-23.08.5
alkimia-8.1.2
alligator-23.08.5
analitza-23.08.5
angelfish-23.08.5
applet-window-appmenu-unstable-2022-06-27
applet-window-buttons-0.11.1
appstream-qt-1.0.2
arianna-23.08.5
ark-23.08.5
attica-5.115.0
audiotube-23.08.5
aura-browser-5.27.11
baloo-5.115.0
baloo-widgets-23.08.5
bismuth-3.1.4
bluedevil-5.27.11
bluez-qt-5.115.0
bomber-23.08.5
booth-1.1.3
bovo-23.08.5
breeze-grub-5.27.11
breeze-gtk-5.27.11
breeze-icons-5.115.0
breeze-plymouth-5.27.11
breeze-qt5-5.27.11
buho-3.1.0
calendarsupport-23.08.5
calindori-23.08.5
clip-3.1.0
colord-kde-23.08.5
communicator-3.1.0
discover-5.27.11
dolphin-23.08.5
dolphin-plugins-23.08.5
dragon-23.08.5
drumstick-2.9.0
dxflib-3.26.4
dynamic_workspaces-1.0.1
elisa-23.08.5
eventviews-23.08.5
falkon-23.08.5
fcitx5-chinese-addons-5.1.5
fcitx5-skk-5.1.3
fcitx5-unikey-5.1.4
fcitx5-with-addons-5.1.9
ffmpegthumbs-23.08.5
filelight-23.08.5
flatpak-kcm-5.27.11
frameworkintegration-5.115.0
futuresql-0.1.1
ghostwriter-23.08.5
gpgme-1.23.2
granatier-23.08.5
grantlee-5.3.1
grantleetheme-23.08.5
gwenview-23.08.5
herqq-unstable-20-06-26
incidenceeditor-23.08.5
index-fm-3.1.0
itinerary-23.08.5
juk-23.08.5
k3b-23.08.5
kaccounts-integration-23.08.5
kaccounts-providers-23.08.5
kactivities-5.115.0
kactivities-stats-5.115.0
kactivitymanagerd-5.27.11
kaddressbook-23.08.5
kalarm-23.08.5
kalgebra-23.08.5
kalk-23.08.5
kalzium-23.08.5
kamoso-23.08.5
kapidox-5.115.0
kapman-23.08.5
kapptemplate-23.08.5
karchive-5.115.0
kasts-23.08.5
kate-23.08.5
katomic-23.08.5
kauth-5.115.0
kblackbox-23.08.5
kblocks-23.08.5
kbookmarks-5.115.0
kbounce-23.08.5
kbreakout-23.08.5
kcachegrind-23.08.5
kcalc-23.08.5
kcalendarcore-5.115.0
kcalutils-23.08.5
kcharselect-23.08.5
kclock-23.08.5
kcmutils-5.115.0
kcodecs-5.115.0
kcolorchooser-23.08.5
kcolorpicker-0.3.1
kcompletion-5.115.0
kconfig-5.115.0
kconfigwidgets-5.115.0
kcontacts-5.115.0
kcoreaddons-5.115.0
kcrash-5.115.0
kdav-5.115.0
kdb-3.2.0
kdbusaddons-5.115.0
kde-cli-tools-5.27.11
kde-gtk-config-5.27.11
kde-inotify-survey-23.08.5
kde2-decoration-1.1
kdebugsettings-23.08.5
kdeclarative-5.115.0
kdeconnect-kde-23.08.5
kdecoration-5.27.11
kded-5.115.0
kdegraphics-mobipocket-23.08.5
kdegraphics-thumbnailers-23.08.5
kdelibs4support-5.115.0
kdenetwork-filesharing-23.08.5
kdenlive-23.08.5
kdepim-addons-23.08.5
kdepim-runtime-23.08.5
kdeplasma-addons-5.27.11
kdesignerplugin-5.115.0
kdesu-5.115.0
kdev-php-23.08.5
kdev-python-23.08.5
kdevelop-pg-qt-2.2.2
kdevelop-with-plugins
kdf-23.08.5
kdiagram-2.8.0
kdialog-23.08.5
kdiamond-23.08.5
kdnssd-5.115.0
kdoctools-5.115.0
kdsoap-2.2.0
keditbookmarks-23.08.5
kemoticons-5.115.0
keysmith-23.08.5
kf5gpgmepp-16.08.3
kfilemetadata-5.115.0
kfind-23.08.5
kgamma5-5.27.11
kgeography-23.08.5
kget-23.08.5
kglobalaccel-5.115.0
kgpg-23.08.5
kguiaddons-5.115.0
khelpcenter-23.08.5
kholidays-5.115.0
khotkeys-5.27.11
khtml-5.115.0
ki18n-5.115.1
kiconthemes-5.115.0
kidentitymanagement-23.08.5
kidletime-5.115.0
kig-23.08.5
kigo-23.08.5
killbots-23.08.5
kimageannotator-0.7.1
kimageformats-5.115.0
kimap-23.08.5
kinfocenter-5.27.11
kinit-5.115.0
kio-5.115.0
kio-admin-23.08.5
kio-extras-23.08.5
kio-gdrive-23.08.5
kipi-plugins-23.08.5
kirigami-addons-0.11.0
kirigami-gallery-23.08.5
kirigami2-5.115.0
kitemmodels-5.115.0
kitemviews-5.115.0
kjobwidgets-5.115.0
kjs-5.115.0
kjsembed-5.115.0
kldap-23.08.5
kleopatra-23.08.5
klettres-23.08.5
klines-23.08.5
kmag-23.08.5
kmahjongg-23.08.5
kmail-23.08.5
kmailtransport-23.08.5
kmbox-23.08.5
kmediaplayer-5.115.0
kmenuedit-5.27.11
kmime-23.08.5
kmines-23.08.5
kmix-23.08.5
kmousetool-23.08.5
kmplot-23.08.5
knavalbattle-23.08.5
knetwalk-23.08.5
knewstuff-5.115.0
knights-23.08.5
knotes-23.08.5
knotifications-5.115.0
knotifyconfig-5.115.0
koko-23.08.5
kolf-23.08.5
kollision-23.08.5
kolourpaint-23.08.5
kompare-23.08.5
kongress-23.08.5
konqueror-23.08.5
konquest-23.08.5
konsole-23.08.5
kontact-23.08.5
kontactinterface-23.08.5
konversation-23.08.5
kopeninghours-23.08.5
korganizer-23.08.5
kosmindoormap-23.08.5
kpackage-5.115.0
kparts-5.115.0
kpat-23.08.5
kpeople-5.115.0
kpeoplevcard-0.1
kpimtextedit-23.08.5
kpipewire-5.27.11
kpkpass-23.08.5
kplotting-5.115.0
kpmcore-23.08.5
kproperty-3.2.0
kpty-5.115.0
kpublictransport-23.08.5
kqtquickcharts-23.08.5
kquickcharts-5.115.0
kquickimageeditor-0.3.0
krdc-23.08.5
krecorder-23.08.5
kreport-3.2.0
kreversi-23.08.5
krfb-23.08.5
krohnkite-0.8.2
kross-5.115.0
kruler-23.08.5
krunner-5.115.0
krunner-ssh-1.0
krunner-symbols-1.1.0
ksanecore-23.08.5
kscreen-5.27.11
kscreenlocker-5.27.11
kservice-5.115.0
kshisen-23.08.5
ksmtp-23.08.5
kspaceduel-23.08.5
ksquares-23.08.5
ksshaskpass-5.27.11
ksudoku-23.08.5
ksystemlog-23.08.5
ksystemstats-5.27.11
kteatime-23.08.5
ktexteditor-5.115.0
ktextwidgets-5.115.0
ktimer-23.08.5
ktnef-23.08.5
ktorrent-23.08.5
ktouch-23.08.5
ktrip-23.08.5
kturtle-23.08.5
kunitconversion-5.115.0
kuserfeedback-1.3.0
kwallet-5.115.0
kwallet-pam-5.27.11
kwalletmanager-23.08.5
kwave-23.08.5
kwayland-5.115.0
kwayland-integration-5.27.11
kweather-23.08.5
kweathercore-0.7
kwidgetsaddons-5.115.0
kwin-5.27.11
kwin-tiling-2.4
kwindowsystem-5.115.0
kwrited-5.27.11
kxmlgui-5.115.0
kxmlrpcclient-5.115.0
kzones-0.6
layer-shell-qt-5.27.11
ldutils-1.10
libcommuni-3.7.0
libdbusmenu-qt-0.9.3+16
libgravatar-23.08.5
libkcddb-23.08.5
libkdcraw-23.08.5
libkdegames-23.08.5
libkdepim-23.08.5
libkexiv2-23.08.5
libkgapi-23.08.5
libkipi-23.08.5
libkleo-23.08.5
libkmahjongg-23.08.5
libkomparediff2-23.08.5
libksane-23.08.5
libkscreen-5.27.11
libksieve-23.08.5
libksysguard-5.27.11
libktorrent-23.08.5
liblastfm-unstable-2019-08-23
libopenshot-0.3.2
libopenshot-audio-0.3.2
libqaccessibilityclient-0.6.0
libqglviewer-2.9.1
libqofono-0.103
libqtav-unstable-2020-09-10
libquotient-0.8.2
lightly-0.4.1
mailcommon-23.08.5
mailimporter-23.08.5
mapbox-gl-qml-2.1.1
maplibre-gl-native-2.0.1
marble-23.08.5
maui-core-0.6.6
mauikit-3.1.0
mauikit-accounts-3.1.0
mauikit-calendar-3.1.0
mauikit-documents-3.1.0
mauikit-filebrowsing-3.1.0
mauikit-imagetools-3.1.0
mauikit-terminal-3.1.0
mauikit-texteditor-3.1.0
mauiman-3.1.0
mbox-importer-23.08.5
merkuro-23.08.5
messagelib-23.08.5
milou-5.27.11
minuet-23.08.5
mlt-7.24.0
modemmanager-qt-5.115.0
neochat-23.08.5
networkmanager-qt-5.115.0
nota-3.1.0
okular-23.08.5
oxygen-5.27.11
oxygen-icons-5.115.0
oxygen-sounds-5.27.11
packagekit-qt-1.1.1
parachute-0.9.1
partitionmanager-23.08.5
phonon-4.11.1
phonon-backend-gstreamer-4.10.0
phonon-backend-vlc-0.11.3
picmi-23.08.5
pim-data-exporter-23.08.5
pim-sieve-editor-23.08.5
pimcommon-23.08.5
plank-player-5.27.11
plasma-applet-caffeine-plus-1.4
plasma-applet-virtual-desktop-bar-unstable-2021-02-20
plasma-bigscreen-5.27.11
plasma-browser-integration-5.27.11
plasma-desktop-5.27.11
plasma-dialer-23.01.0
plasma-disks-5.27.11
plasma-framework-5.115.0
plasma-integration-5.27.11
plasma-mobile-5.27.11
plasma-nano-5.27.11
plasma-nm-5.27.11
plasma-pa-5.27.11
plasma-phonebook-23.01.0
plasma-remotecontrollers-5.27.11
plasma-sdk-5.27.11.1
plasma-settings-23.01.0
plasma-systemmonitor-5.27.11
plasma-thunderbolt-5.27.11
plasma-vault-5.27.11
plasma-welcome-5.27.11
plasma-workspace-5.27.11
plasma-workspace-wallpapers-5.27.11
plasmatube-23.08.5
polkit-kde-agent-1-5.27.11
polkit-qt-1-0.114.0
polonium-1.0rc
poppler-qt5-24.02.0
powerdevil-5.27.11
print-manager-23.08.5
prison-5.115.0
pulseaudio-qt-1.3.0
purpose-5.115.0
qca-2.3.8
qcoro-0.10.0
qcsxcad-unstable-2023-01-06
qjson-0.9.0
qmake-hook
qml-box2d-unstable-2022-08-25
qmlkonsole-23.08.5
qmltermwidget-unstable-2022-01-09
qoauth-2.0.0
qqc2-breeze-style-5.27.11
qqc2-desktop-style-5.115.0
qscintilla-qt5-2.13.2
qt3d-5.15.12
qt5ct-1.8
qtbase-5.15.12
qtcharts-5.15.12
qtconnectivity-5.15.12
qtcurve-1.9.1
qtdatavis3d-5.15.12
qtdbusextended-0.0.3
qtdeclarative-5.15.12
qtdoc-5.15.12
qtfeedback-unstable-2018-09-03
qtforkawesome-0.1.0
qtgamepad-5.15.12
qtgraphicaleffects-5.15.12
qtimageformats-5.15.12
qtinstaller-2.0.3
qtkeychain-0.14.2
qtlottie-5.15.12
qtmpris-1.0.6
qtmultimedia-5.15.12
qtnetworkauth-5.15.12
qtpbfimageplugin-3.0
qtpim-unstable-2020-11-02
qtpositioning-5.15.2
qtquickcontrols-5.15.12
qtquickcontrols2-5.15.12
qtremoteobjects-5.15.12
qtscript-5.15.16
qtscxml-5.15.12
qtsensors-5.15.12
qtserialbus-5.15.12
qtserialport-5.15.12
qtspeech-5.15.12
qtstyleplugin-kvantum5-1.1.1
qtstyleplugins-unstable-2017-03-11
qtsvg-5.15.12
qtsystems-unstable-2019-01-03
qttools-5.15.12
qttranslations-5.15.12
qtutilities-6.14.0
qtvirtualkeyboard-5.15.12
qtwayland-5.15.12
qtwebchannel-5.15.12
qtwebengine-5.15.16
qtwebglplugin-5.15.12
qtwebkit-5.212.0-alpha4
qtwebkit-plugins-unstable-2017-01-25
qtwebsockets-5.15.12
qtwebview-5.15.12
qtx11extras-5.15.12
qtxmlpatterns-5.15.12
quazip-1.4
quickflux-1.1-unstable-2020-11-10
qwt-6.2.0
qxlsx-1.4.7
qzxing-3.3.0
rlottie-qml-0-unstable-2021-05-03
rocs-23.08.5
sddm-kcm-5.27.11
sddm-wrapped
shelf-3.1.0
sierra-breeze-enhanced-1.3.3
signond-8.61-unstable-2023-11-24
skanlite-23.08.5
skanpage-23.08.5
solid-5.115.0
sonnet-5.115.0
soqt-2020-12-05-unstable
soundkonverter-3.0.1
spacebar-23.01.0
spectacle-23.08.5
station-3.1.0
syndication-5.115.0
syntax-highlighting-5.115.0
systemsettings-5.27.11
telepathy-qt-0.9.8
telly-skout-23.08.5
threadweaver-5.115.0
tokodon-23.08.5
umbrello-23.08.5
vvave-3.1.0
wrap-qt5-apps-hook
xdg-desktop-portal-kde-5.27.11
xp-pen-deco-01-v2-driver-3.4.9-231023
xp-pen-g430-driver-1.2.13.1
yakuake-23.08.5
yuview-2.13
zanshin-23.08.5

Those that did not install are akonadi-mime, fcitx5-configtool, fcitx5-qt, full, kdevelop-unwrapped, kitinerary, kmail-account-wizard, mapbox-gl-native, and pix.

Lastly, I had to copy plasma-kactivitymanagerd.service from libsForQt5.kactivitymanagerd to /usr/lib/systemd/user, to be usable from Plasma.

I could not figure a way to launch Plasma automatically, so I just did startplasma-wayland. I got to the logo screen, but then it just went black and nothing happened. Here is the error log:

start_kdeinit: No such file or directory
No backend specified, automatically choosing drm
pci id for fd 20: 80ee:beef, driver (null)
MESA-LOADER: failed to open vboxvideo: /run/opengl-driver/lib/dri/vboxvideo_dri.so: cannot open shared object file: No such file or directory (search paths /run/opengl-driver/lib/dri, suffix _dri)
MESA-LOADER: failed to open kms_swrast: /run/opengl-driver/lib/dri/kms_swrast_dri.so: cannot open shared object file: No such file or directory (search paths /run/opengl-driver/lib/dri, suffix _dri)
MESA-LOADER: failed to open swrast: /run/opengl-driver/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory (search paths /run/opengl-driver/lib/dri, suffix _dri)
kwin_wayland_drm: Atomic Mode Setting disabled on GPU /dev/dri/card0 because of cursor offset issues in virtual machines
kwin_scene_opengl: Creating the OpenGL rendering failed:  "Missing one or more extensions between EGL_EXT_platform_base, EGL_MESA_platform_gbm, EGL_KHR_platform_gbm"
kwin_scene_opengl: Creating the OpenGL rendering failed:  "Could not initialize egl"
kwin_xkbcommon: XKB: inet:323:58: unrecognized keysym "XF86EmojiPicker"
kwin_xkbcommon: XKB: inet:324:58: unrecognized keysym "XF86Dictate"
kwin_xkbcommon: XKB: inet:325:58: unrecognized keysym "XF86CameraAccessEnable"
kwin_xkbcommon: XKB: inet:326:58: unrecognized keysym "XF86CameraAccessDisable"
kwin_xkbcommon: XKB: inet:327:58: unrecognized keysym "XF86CameraAccessToggle"
kwin_xkbcommon: XKB: inet:357:58: unrecognized keysym "XF86NextElement"
kwin_xkbcommon: XKB: inet:358:58: unrecognized keysym "XF86PreviousElement"
kwin_xkbcommon: XKB: inet:359:58: unrecognized keysym "XF86AutopilotEngageToggle"
kwin_xkbcommon: XKB: inet:360:58: unrecognized keysym "XF86MarkWaypoint"
kwin_xkbcommon: XKB: inet:361:58: unrecognized keysym "XF86Sos"
kwin_xkbcommon: XKB: inet:362:58: unrecognized keysym "XF86NavChart"
kwin_xkbcommon: XKB: inet:363:58: unrecognized keysym "XF86FishingChart"
kwin_xkbcommon: XKB: inet:364:58: unrecognized keysym "XF86SingleRangeRadar"
kwin_xkbcommon: XKB: inet:365:58: unrecognized keysym "XF86DualRangeRadar"
kwin_xkbcommon: XKB: inet:366:58: unrecognized keysym "XF86RadarOverlay"
kwin_xkbcommon: XKB: inet:367:58: unrecognized keysym "XF86TraditionalSonar"
kwin_xkbcommon: XKB: inet:368:58: unrecognized keysym "XF86ClearvuSonar"
kwin_xkbcommon: XKB: inet:369:58: unrecognized keysym "XF86SidevuSonar"
kwin_xkbcommon: XKB: inet:370:58: unrecognized keysym "XF86NavInfo"
kwin_wayland_drm: Setting gamma failed! Function not implemented
Xwayland glamor: GBM backend (default) is not available
kwin_scripting: Component failed to load:  (file:///home/user/.nix-profile/share/kwin/scripts/Parachute/contents/ui/main.qml:119:13: Type ScreenComponent unavailable
                ScreenComponent {
                ^, file:///home/user/.nix-profile/share/kwin/scripts/Parachute/contents/ui/ScreenComponent.qml:177:13: Type DesktopComponent unavailable
                DesktopComponent { // Cannot set geometry of SwipeView's root item
                ^, file:///home/user/.nix-profile/share/kwin/scripts/Parachute/contents/ui/DesktopComponent.qml:197:19: Type ClientComponent unavailable
            delegate: ClientComponent {}
                      ^, file:///home/user/.nix-profile/share/kwin/scripts/Parachute/contents/ui/ClientComponent.qml:168:9: Cannot assign to non-existent property "renderTarget"
            renderTarget: KWinComponents.ThumbnailItem.FramebufferObject
            ^)
failed to acquire GL context to resolve capabilities, using defaults..
This plugin does not support setting window masks
This plugin does not support setting window masks
file:///home/user/.nix-profile/share/kwin/scripts/kzones/contents/ui/main.qml:526:17: QML Rectangle: Binding loop detected for property "height"
Failed to initialize glamor, falling back to sw
qt.qpa.wayland: EGL not available
Warning: fallback to QtQuick software backend.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported maximum keycode 708, clipping.
>                   X11 cannot support keycodes above 255.
Errors from xkbcomp are not fatal to the X server
Initializing  "/nix/store/pqdfsjhjx370np3vnbyirjs00a6lmpkv-plasma-workspace-5.27.11/lib/qt-5.15.12/plugins/plasma/kcms/systemsettings/kcm_style.so"
Initializing  "/nix/store/pqdfsjhjx370np3vnbyirjs00a6lmpkv-plasma-workspace-5.27.11/lib/qt-5.15.12/plugins/plasma/kcms/systemsettings/kcm_fonts.so"
Initializing  "/nix/store/6f2gbki3qqkd3l59q3jqaxsn2llp7axl-plasma-desktop-5.27.11/lib/qt-5.15.12/plugins/plasma/kcms/systemsettings/kcm_mouse.so"
org.kde.plasma.session: process job  "kcminit_startup" finished with exit code  0
qt.qpa.wayland: EGL not available
Warning: fallback to QtQuick software backend.
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
Warning: fallback to QtQuick software backend.
Qt: Session management error: networkIdsList argument is NULL
Initializing  "/nix/store/6y8wmjbcyz8izl2r22aihxwdfv4rsah6-kgamma5-5.27.11/lib/qt-5.15.12/plugins/plasma/kcms/systemsettings/kcm_kgamma.so"
Initializing  "/nix/store/6f2gbki3qqkd3l59q3jqaxsn2llp7axl-plasma-desktop-5.27.11/lib/qt-5.15.12/plugins/plasma/kcms/systemsettings/kcm_touchpad.so"
kf.config.core: "\"fsrestore1\" - conversion of \"0,0,0,0\" to QRect failed"
qt.qpa.wayland: EGL not available
Warning: fallback to QtQuick software backend.
QDBusConnection: name 'org.freedesktop.UDisks2' had owner '' but we thought it was ':1.23'
QDBusConnection: name 'org.freedesktop.UPower' had owner '' but we thought it was ':1.24'
Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running.
If this Plasma has been installed into a custom prefix, verify that its D-Bus services dir is known to the system for the daemon to be activatable.
kf.notifications: env says KDE is running but SNI unavailable -- check KDE_FULL_SESSION and XDG_CURRENT_DESKTOP
colord: X11 not detect disabling
org.kde.libkbolt: Failed to connect to Bolt manager DBus interface: The name is not activatable
org.kde.bolt.kded: Couldn't connect to Bolt DBus daemon
Installing the delayed initialization callback.
Delayed initialization.
Reloading the khotkeys configuration
Version 2 File!
true
Imported file "/home/user/.nix-profile/share/khotkeys/defaults.khotkeys"
Imported file "/home/user/.nix-profile/share/khotkeys/kde32b1.khotkeys"
Imported file "/home/user/.nix-profile/share/khotkeys/konqueror_gestures_kde321.khotkeys"
kf.auth: Tried to start an invalid action:  "org.kde.kded.smart.smartctl"
kf.modemmanagerqt: Failed enumerating MM objects: "org.freedesktop.DBus.Error.NameHasNoOwner" 
 "Could not activate remote peer 'org.freedesktop.ModemManager1': activation request failed: unknown unit"
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
org.kde.kmix: no mix devices and not dynamic
xsettingsd: Loaded 14 settings from /home/user/.config/xsettingsd/xsettingsd.conf
xsettingsd: Created window 0xe00001 on screen 0 with timestamp 993528
xsettingsd: Selection _XSETTINGS_S0 is owned by 0x0
xsettingsd: Took ownership of selection _XSETTINGS_S0
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
kf.bluezqt: PendingCall Error: "The name is not activatable"
kf.bluezqt: PendingCall Error: "Could not activate remote peer 'org.bluez': activation request failed: unknown unit"
Registering ":1.14/StatusNotifierItem" to system tray
kscreen.kded: PowerDevil SuspendSession action not available!
Initializing  "/nix/store/pqdfsjhjx370np3vnbyirjs00a6lmpkv-plasma-workspace-5.27.11/lib/qt-5.15.12/plugins/plasma/kcms/systemsettings/kcm_fonts.so"
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  12
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  13
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  14
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  15
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  16
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  17
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  12
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  13
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  12
org.kde.kmix: Channel Map contains a pa_channel_position we cannot handle  13

I am not really sure which line (if any at all) relates to the issue, or what it is that I missed (I suppose many things). I had tried to look at Nix-related resources for installing KDE, like this one, but it is for NixOS and does not seem to apply just to the package manager (not sure if Home Manager can use it).

What should I do?

1
  • Why not just install NixOS with KDE Plasma 5? Or install a non-rolling-release distro that's already based on Plasma 5? Commented May 10 at 23:58

1 Answer 1

0

Start Over

Remember that Nix should be used to build your development environment on top of your existing OS, not force an install of a Desktop Environment that Arch decided to upgrade, and since EndeavorOS is a child of Arch, you're stuck with that design decision.

NixOS builds packages differently than traditional package managers, in that each package is delivered to the package store with it's dependencies included. As the OP has found out, NixOS cannot build Meta-Packages, and because these packages are meant to be deployed to a Development Environment - See Item 4, they are not meant to be installed on the host system.

As such, I would do the following (Assuming you want to keep Endeavour as the host):

  1. Uninstall Nix
  2. Update EndeavourOS
  3. Reinstall Nix
  4. Use the Docker Tools Image Helpers in the NixPkgs to build a VM that includes KDE5, and then develop inside the VM.

Optional

The OP may be overthinking the approach taken. KDE adds support packages to help with transitioning to newer versions. All that may need to be done is to install the Plasma5Support package from the Arch Repository.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .