0

I have an NTFS partition on an HD. This partition contains 6 files which I can't read in any way. I have tried reading them as root, doing chmod, chown and mount -o rw,remount ... nothing worked.

# ls -l
total 1544780
-rwxrwxrwx 1 tomas tomas 611063388 Nov 14  2014 TRE_8446.MOV
-rwxrwxrwx 1 tomas tomas 609181132 Nov 14  2014 TRE_8447.MOV
-rwxrwxrwx 1 tomas tomas 177475992 Nov 14  2014 TRE_8448.MOV
-rwxrwxrwx 1 tomas tomas  19260420 Nov 14  2014 TRE_8449.MOV
-rwxrwxrwx 1 tomas tomas  43750628 Nov 14  2014 TRE_8450.MOV
-rwxrwxrwx 1 tomas tomas 121110004 Nov 14  2014 TRE_8452.MOV
# file TRE_8446.MOV
TRE_8446.MOV: ERROR: cannot read `TRE_8446.MOV' (Permission denied)

Any idea why this issue? It's blowing my mind

11
  • What are the permissions on the parent directory?
    – tink
    Commented May 4 at 21:32
  • @tink: The fact that the OP can do ls -l successfully suggests that they have all the directory access they could possibly need. Commented May 4 at 21:46
  • On the other hand, yes, user2543740, if you have a question about permissions, you might as well do ls -la and show the information for . and ... Commented May 4 at 21:46
  • Are they "special" in some way? For example, compressed, or in a OneDrive / Google Drive / Dropbox type directory where they appear to be present but actually are not? Commented May 4 at 22:14
  • Explore your Mount/Read/Write/Execute problems with https://github.com/waltinator/pathlld, a bash script to show the permissions, mount options along the path to an object or objects.
    – waltinator
    Commented May 4 at 22:16

1 Answer 1

1

I'm 99% sure you've got a FS corruption. Run chkdsk /f d: (use the proper letter) from Windows.

3
  • I have tried and windows does not detect any errors on the disk with ckdsk /f d: Commented May 16 at 11:08
  • Is the issue still reproducible after running chkdsk? If it is, send an email to ntfs3 AT lists.linux.dev Commented May 17 at 8:03
  • yes, will do as soon as possible thx Commented May 21 at 14:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .