0

I am following a tutorial to install Oracle 19c on Oracle Linux 9.

If I run the installer (runInstaller) as a non-root user, I get a permissions denied error. But if I run it with sudo, I get Oracle's 'cannot run it as root'. I don't know what to do now. Here is the error for reference:

enter image description here

I have tried installing the 19c database on Ubuntu. And although, I got the installer running, it just didn't work very well. So, I tried it on Oracle Linux 9. But I keep getting the above error.

1 Answer 1

0

you haven't made your installer file executable; chmod 755 runInstaller should fix that.

General remark: you're paying dear money for Oracle's commercial database (instead of running MariaDB or PostgresQL for free), so don't hesitate to make use of the support you pay for! And, instead of some pretty complicated tutorial that lets you do things that neither of the two of us understand, you might fare better with the official documentation, which is one single command if you're an ULN subscriber, or two commands if you're not. Instead of multiple pages of text…

1
  • Changing permissions didn't work, however going through the official documentation did. I am amazed at how easy it was to install and I wasted so much of my time on this. You definitely saved me a lot of trouble. Btw, I haven't paid any money to use it. I certainly prefer PostgreSQL, but I have to use Oracle for learning purposes. Commented May 2 at 10:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .