3

I've gone through the following articles doing the steps to ensure that thunderbird will open links in Chromium instead of Firefox:

Everywhere else in KDE, things open appropriately in the right browser (chromium). I've tried clobbering my profile, and starting again from scratch.

I'm at a loss here, I can't figure out why everything else is using chromium as the default browser, but thunderbird continues to use firefox, no matter what.

I'm running ArchLinux, in KDE, and I've set up chromium as the default browser.

migrated from serverfault.com May 29 '13 at 16:42

This question came from our site for system and network administrators.

  • 2
    Does changing the association in Menu preferences -> tab attachments -> HTML files resolve the problem? – lgeorget May 29 '13 at 16:47
  • ERMAGHERDS @lgeorget, yes, that's the problem. Put it in the answers, and I'll be more than happy to give you credit. – BeepDog May 29 '13 at 18:22
  • In fact, you could accept voretaq7's answer which gives the same solution with more details and explanation. – lgeorget May 30 '13 at 2:28
5

Not really sure this is a unix-specific thing - it sounds like you've got KDE's associations properly configured and Thunderbird is a bad Desktop Environment citizen that ignores them <insert disapproving glare here>.

Thunderbird does have its own list of associations that determine what it does with attachments.
This Arch BBS post is a little old, but has the details on what you need to change.

They provide three possible solutions which I'll summarize here for completeness
(in order of increasing nasty hackishness):

  1. In your Thunderbird configuration (Edit -> Preferences -> Attachments), specify Chromium as the application to handle HTTP and HTTPS URLs.
  2. Do basically the same thing as (1) manually by editing user.js
    This is a "nicer" way than (3), but you should really use the menu options if at all possible.
  3. Do basically the same thing as (1) manually by editing Thunderbird's mime types file by editing ~/.thunderbird/profile_name/mimeTypes.rdf.
    (The linked discussion thread provides an example, but editing the file should be pretty self-explanatory)

(Note they also talk about manually hacking the MIME info cache in the thread I linked to in #2 - This will probably work, but it's kind of disgusting and potentially fragile so I wouldn't recommend it. Of course if nothing else works and you're OK with dirty hacks…)

  • 1
    I have done all these things already. Turns out @lgeorget's solution is the problem. There's a third place that deals with HTML links :( – BeepDog May 29 '13 at 18:22
  • Turns out I hadn't done the Preferences - attachments solution – BeepDog May 31 '13 at 2:57
2

Thunderbird and Firefox have their own way to deal with file types. This allows you to define different actions for different kind of files (not downloading them in the same directory, etc.).

You can modify your preferences in Menu preferences -> tab attachments -> HTML files.

Tab 'attachments'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.