0

transmission 4.0.5-1 Arch 6.8.5-arch1-1

I want to edit /var/lib/transmission/.config/transmission-remote/settings.json. Permissions on that file are 600 for transmission:transmission

My user is in the transmission group so I run chmod 660 settings.json and make my changes

I could make the changes as root but I prefer this approach.

However Transmission resets permission on every stop/start so I have to do this every time I want to make a change to the file.

I must be doing it wrong. What is the preferred approach here?

1 Answer 1

0

It seems you can set a umask value inside settings.json (as explained here and here)

You have to convert it to base 10. You can do this in the shell like this:

$ echo $(( 8#002 ))
2

So change value of umask like this in settings.json like this:

"umask": 2

Then reload your transmission service

1
  • Thanks but this sets the permissions on the downloaded files, not on the config directory. Commented Apr 23 at 23:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .